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Overview & Layout
The main view of the application can be divided in 6 sections:
Menu Bar
Function Bar
Tab 1

Tab 1

X

Tab 2

X

Tab 3

X

Tab 4

Menu Bar

Settings and features
shared by the whole
application

Function Bar

Common functions,
specialized functions,
often used tools.

Status Bar

Information about the
user, fleet deviation,
connection status

Tool Windows

Areas with tools/plugins

X

X

Tab 2

Top Tool Window

X

Tab 3

Left Tool
Window

X

Tab 1

X

Tab 2

X

Tab 3

X

Bottom Tool Window
Status Bar

Each tool window has its own tabs with icon and name.
• The active tab is highlighted in orange. The visible, inactive tabs are grey.
• A tab with new information has a bright yellow background.
• Close a tab by clicking on the upper right X.
• A dark arrow in the tab bar means that there are more tabs than there is
place. Click on the arrow to show a selectable list.
• Dock out a tool by left-clicking on its tab and holding down the button until
it turns orange, then dragging it out. The tool becomes its own floating
window which can be placed anywhere on your screen(s). Dock it back by
clicking on the "Docking back" button
.
The Left and Bottom Tool Windows have a grey arrow
to minimize/maximize
their contents to give more space to the Top Tool Window.

Disconnect

Create Diagnostics Zip

You need to disconnect to change
settings. You can either...
• Menu Bar: File -> Disconnect

If you have a problem with Traffic Studio, click on the
button Diagnostics in the Function Bar
to create a
diagnostics file set covering all relevant diagnostic logs.

• Function Bar: Click on

.

Connect
You can either...
• Menu Bar: File -> Connect.

You will be prompted to add a short description before
creating the zipped file in a folder of your choice. Make
sure to include it with your JIRA ticket.

Database Access
You can see your access to the
databases in the right lower
corner of the status bar.

XYZ (75) refers to all active vehicles in the system
having sent a vehicle report within 30* minutes
(default settings), including ABC.

.

Everything is great.
There is connection issues with
at least one database.

Hold your mouse over the clock
& time in the lower right corner
to show the system time, date
and time zone.

Vehicle Counter
The Vehicle Counter shows two
numbers ABC (XYZ). ABC (53)
refers to the number of vehicles
currently servicing a journey.

• Function Bar: Click on

Time Tooltip

Turn Off Notifications (temporarily)
You can temporarily close notifications (popup in the right lower
corner) via the Menu Bar. Click on View ->Disable Notifications, to
close them until your next Traffic Studio session. You can select
Configure Notifications if you only want to turn off specific types.

Punctuality Overviews
There are two Punctuality
overviews in the status bar.
Bring your mouse pointer over
the pie chart or the vehicle
counter to see them.
The top wheel shows timetable
deviation from the passengers'
perspective (requires APC).
The bottom wheel shows the
same, but from the vehicles'
perspective.

To turn them off for good, check out the plugin's own settings.
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IMPORTANT! Traffic Studio uses Transmodel terminology, which can differ in different
parts of the world. In this section, we have added other known variations within
parenthesis. However, the rest of the manual will only be using TransModel.

Stop Area
A group of stop points located close
to each other within the same area.
E.g.

Central Station
Maple Street
Arena
Market Place

What Do We Mean by That

Stop Point

{

A point where passengers can
board on/alight from vehicles.
E.g. Central Station A
Maple Street 2

Timing Point
A stop point usually used for
regulating timetables.
The vehicle must leave this stop
point on time (never earlier).
This information is available to the
drivers through their interface.

Wait, what's that dotted circle?
I'm glad you asked! CTS uses a larger area
around each stop point to help detecting various
types of events, like arrivals, departures, passby, etc. The default value is 25 meter radius.
You can also use geofences to draw your own
area, which can be useful for large terminals,
long streets, etc.
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What Do We Mean by That
Start point

Route (Route Variant)

Line 42

An ordered list of stop points, links and
destination. E.g. Route 1701 and Route 1138.

Line (Route )

Route 1138
Route 1701
Destination
Line 42 has 2 routes between Start point and Destination; Route 1701 (blue) & Route 1138 (orange)
• Journey AAA: 06.35 - 07.15, Line 42, Route 1701
• Journey CCC: 07:45 - 08.20, Line 42, Route 1701
• Journey UUU: 08:40 - 09:25, Line 42, Route 1138

A group of routes with a designation. E.g.
Line 42 is made of both Route 1701 and
Route 1138.

Journey (Trip)
A route with a date, a start time and an end
time. Each journey is unique and has its
own ID.

Block (Run)
A collection of journeys assigned to a vehicle. They are unique and
usually last one day.
E.g. This block is made of 3 journeys:
• Central Station from 9.10- Maple street at 10.05
• Maple Street from 10.25 - Arena at 11.20
• Arena from 12.00 - Market Place at 12.30

Central Station

Depot

Market Place

Arena

Duty (Shift)
A collection of journeys assigned to a driver. They are unique and
usually last one day. A driver may change vehicles during a shift.

Maple Street

Note: Some blocks/duty can include journeys, often called empty runs,
which are from and to the depot (dotted lines in the illustration).
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What Do We Mean by That

Off Route
The vehicle is driving
outside the radius of a
link point.
Off route (and on
route) is automatically
detected by the system.
While off route, the
vehicle continues to
report and can still be
followed step-by-step in
Traffic Studio.
Depending on your
configuration, things
such as forecasts and
passenger information
can behave differently.

Link
A link is the geography between two
stop points.
It has a length in meters and is
usually divided in points-in-link to
increase its accuracy.
The default settings is 100 m between
each point-in-link, but this varies
greatly depending on the distance
between the stop points. It can also be
configured to another value.
Each point-in-link is in the middle of
a circle with a radius equals to 70%
of the distance between itself and the
next point on the route. A vehicle is
considered off route if it goes outside
the radius.

CONSAT TELEMATICS

Traffic Studio - Training Material

| p. 8

Forecasts

Forecasts are calculated using vehicle reports, planned traffic data and
historical data. The vehicle reports contain the information about the
vehicle’s whereabouts and its deviation to the timetable.

Previous (5) buses

The odometer calculates the distance driven by the vehicle by counting
the number of times its wheels have rotated. Using the measured
distance between stop points, it can pinpoint fairly accurately the
vehicle’s position along the route and how far it is from the next stop
point. While GPS could be used, it does not take into account the position
in relation to the whole route.
E.g., a route has a large curve before reaching the stop point. In the
example above, the GPS would tell us that the vehicle is almost there,
while the odometer would know that there is still a bit left and thus
adjust the time accordingly.
The forecast also uses the historical data of the previous five* vehicles,
regardless of their line, as long as they share the same link. It looks at
their driving time along the link and their stay time at the next stop
point, in order to adjust the forecasts to the latest traffic situations.
* configurable
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Communication

Control Centers

Software /
Traffic data management

Vehicles

Passenger Information
on Websites and Mobiles

Wireless Network
Central System

Displays at Stop Point

Equipped with GPRS devices, the
vehicles use a wireless network to
communicate back and forth with the
Software/Traffic data management.

The Software/Traffic data management
communicates with the Central System
to relay the information received from
the vehicles, but also to get updates on
timetables and other traffic planning data.

The Central System gathers the information
and sends it to the various users, i.e. the
various displays at the stop points, the
Control Centers where users are working with
Traffic Studio, websites and mobile apps.
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Vehicle Reports & Stop Points

What kind of information can we expect from the vehicles?
Most tools, unless they are based on planned traffic data,
require real-time data to provide you with information. To
do so, each vehicle sends reports at predefined events. Is that
often? It can be! Keep in mind that CTS monitors over 200
different types of events. Each time one of these happen, we
get new information about the vehicle.
Examples of some predefined events:
• Arrive at stop point
• Door open
• Departure from stop point
• Pass by stop point
• Off route
• GPS direction
• Odometer value
• Manual repositioning
• Stop request from passengers

25 meters radius
showing the stop point’s
limits in the system.

300* meters or 30*
seconds from the next
stop point.

4, 5, 6, 7, 8, 9
2,3

10a, 11

1

1

If the distance between
the stop points is less
than 300*m or 30*s
away, the call is made as
the bus departs from its
stop point.

1

10b, 11
2,3
1

But... what happens if nothing happens?
We have thought about it and made it so that if we have not
heard from the vehicle in 10* seconds, then the vehicle will
send a report with its position.

Event Reports from the vehicle

The vehicle will also send a report each time its deviation
from the timetable increases/decreases by 30* seconds.

2 At stop The vehicle enters the stop point’s radius.

1 Internal call An announcement is made through the vehicle’s internal speakers.
3, 6, 19, 11 Update displays The content of the internal displays is updated.
4 Door open The doors open.

Active Vehicles

5 Arrive at stop point When the vehicle is within the circle and has sent a Door
open report.

Real-time plugins only show active vehicles to avoid a clutter
of inactive vehicles.

7 External call An announcement is made through the vehicle’s internal speakers.

Vehicles are considered active if they have sent a vehicle
report within the last 30* minutes. After that, they are
hidden from plugins such as Map, Lines, Active Vehicles,
Line Overview, Line Viewer, Traffic Status, etc.

10a Departure from stop point When leaving the stop point’s radius, if reports #4
& #5 were sent.

You can always find inactive vehicles via Search Vehicles,
Stop Point History, Customer Support, etc.

8 Door close The doors close.

10b Pass by stop point When leaving the stop point's radius, if no reports #4 & #5
were sent.
* configurable
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Driver Interface
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The Driver Interface is shown via a touchscreen monitor installed on-board the
vehicles. The screen is locked while the vehicle is in movement, for safety reasons.
The Driver Interface varies between systems as there are a multitude of functions to
select, some basics and some optional.

Basic Information
The vehicle icon field shows real-time information like
stop request, passenger counter information, active
faults, signal priority, signal strength, etc.
The destination sign is displayed below the vehicle
icon, showing its exact content, which usually includes
the line number, destination name and any via
destination. It can also show symbols for school bus,
airport coach, etc.
Assignment information, such as block, line, journey
and driver ID/name, is displayed at the bottom of the
screen.

Journey View
The Journey View shows the next five stop points
along the assigned route and the vehicle position
(blue arrow). Each row shows a stop, with its
planned departure time, the type of stop (normal,
timing, interchange, cancelled, etc.), and the
distance to the next stop as the vehicle travels.
Optional information which can be displayed:
• When a STOP button is pressed (e.g., King's Crossing Mall)
• Interchange/connections at the next stop point (e.g., Rita)
• Driver Coaching summary at the end of a journey (e.g., Central Park)
• Cancelled stop point (x in the stop symbol, e.g., Dalabor)
• Stop point with only boarding/alighting (text next to the timetable text)
• Reinforcing vehicles (yellow arrows)

Manual signage and assignment are denoted with a
hand symbol to the left of their respective field.

Timetable Deviation Barometer
The barometer updates in real-time with the vehicle's current
deviation to the timetable. The barometer has both the exact
deviation in numbers, and a visual indicator with red (early) and
green (on-time or late) areas.

Driver Coaching and Map (options)
The Journey View and the Barometer can be replaced by a
map, showing the planned route and the vehicle's position in
real-time.
Driver Coaching events are displayed when they are triggered,
informing the driver at the exact time and place where they
did an action deemed contrary to acceptable driving behavior.
It is also possible to monitor fuel consumption.
Such instant feedback is helpful for the driver to be able
identify which behavior is problematic and what might be its
cause, so they can learn and improve their driving skills for
everyone's benefit.

Notification Center
The Notification Center has various sections for text
messages, traffic information meant for the driver and
the passengers, traffic deviations and so-called “actions”,
i.e., custom system functions used for
1
interaction with traffic controllers, etc.
A red square appears whenever the
Notification Center has new
information for the driver,
along with the number of
messages/alerts.
1
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Settings | Vehicle Presentation
Function

Configure the content of labels and tooltips; various settings; the
appearance of vehicle symbols; and create/manage line groups.
These settings affect only your account.

Access

Disconnect
File -> Setup -> Vehicle Presentation

Vehicle Tooltip

Vehicle (Identity)

Add information by ticking the
relevant check boxes.

To include additional information for the
vehicle in various plugins, e.g., "vehicle" in
Active Vehicles.

"Show title" will add its name, e.g.,
"Line 31" instead of just "31".
Use the grey arrows on the side to
change their order.

Line Groups

Vehicle Label

Add, remove and edit line groups. It shows 3 tabs: Selected,
Selection and Filter (regex). Please refer to
the manual for more information about
how to use regex in selecting lines.

Include information in a label by ticking the check box
in the column to the right. There is no limit, but that can
result in a very wide label box.

Presentation
"Ignore vehicle reports older than" will change how long a
vehicle is considered active in the system.
“There is an assignment system” is used for central
assignment. When the box is ticked, the application will
give a warning if the vehicle’s assignment differs from the
one made by the assignment system.
The dashed trail replaces the normal full path driven by a
vehicle when there is a large gap between reports, either
time-wise or distance-wise. It can also be used for invalid
GPS-positions.
Tabs
Vehicles have different colors depending on their timetable
deviations or status (training, charter, etc.). In these tabs, you
can change the color, size and time deviation limit for each
category. The size is in meter and scales with the map.

How to add a group
1. Click on Add.
2. Name your group. The button Add
will change to Save. Click on this
Save button again (not the one at the
bottom of the window).
3. Tick the check boxes in the Selection
tab to include lines in your new group.
You can check which lines are included
in your group by looking at the tab Selected.
4. Create more groups, or click on Save at the
bottom of the window to finish.
How to edit a group
1. Select a group under Group name.
2. In the Selection tab, add/remove lines from your group, then
click on Save at the bottom of the window to finish.
How to remove a group
1. Select a group under Group name.
2. Click on Remove.
3. Click on Save at the bottom of the window to finish.
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Settings | Tooltips & Labels, Map
Function

Configure the information included in labels and tooltips for
blocks/duties, lines, drivers, stop areas/points, journeys and
Company.
These settings affect only your account.

Access

Disconnect
File -> Setup -> Tooltips and Labels

Access

Disconnect
Go to File -> Setup -> Map

1. Select the relevant tab.
2. Tick the Label: Value box to include the information in
tables, search criteria, etc.
3. Tick the Tooltip: Value and/or Tooltip: Title boxes to
include the information in tooltips.
4. Use the grey arrows on the side to change the order of
the content.
5. Click on Save. Note that this will close the window.
We suggest that you do all the changes you need in all
the tabs before saving to save yourself some time and
hassle.

Function

Select the starting location and zoom level of your Tile Map.
These settings affect only your account.

1. Set your position and zoom level.
1.1 Use latitude and longitude coordinates
1.2 Use the map on the right side to navigate to the
desired location. You can zoom in and out to the
level of your choice.
2. Click on Save.
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Active Vehicles
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Function
Access

Table with all active vehicles with
real-time updates.
Tools -> Vehicles -> Active Vehicles

Filter the Selection
Filter the table with global line group, company,
interval, free text search, active fault and vehicle
groups.

Table Content
The table provides real time information about each
vehicle. New information is updated with a yellow
fading background.
Vehicles with the journey status "Between" show
the information for the next journey with an arrow
symbol (->) before line, destination and journey.
Filter the table by using "dash" (-), immediately
followed by "larger than" (>).

Line Group
The Line Group is located in the Function bar. You
can create more groups under Setup -> Vehicle
Presentation.

Tips
• Adjust the table to your preferences
• Sort the table by clicking on the column of your
choice.
• Reorder the columns by dragging & dropping their
header where you want them.
• Add/remove columns by right-clicking anywhere
on the headers and unchecking them in the list.
• Traffic Studio will remember your configurations.
• Double-click on a row for the map to zoom in on the
vehicle.
• Right-click on any row to open the vehicle shortcut
menu.

Bar Graph
Filters and Search
The drop-down filters and check box
automatically update the table.
Type numbers/text in the search field to update
the table and highlight the cells containing these
characters.
Click on the magnifier icon to activate a search
field for each column, independent of one
another.

The bar graph shows the amount of communicating
vehicles, split by category; AMS and NVS.
Each bar represents the number of reports received
over an interval of 15 minutes, for the current
calendar day (00:00 to 23:59).
The bar graph is minimized by default. Click on the
chart button to maximize it in the Active Vehicles
plugin.

Communication Categories
AMS reports are related to positions, door
opening, deviations, etc. Most reports are in
this category.
NVS reports are related to the vehicle asking
the depot about its software version.

The horizontal red line indicates the current time
and moves accordingly.

Symbols
The vehicle’s symbols represent their
deviation from the timetable and status.
The colors, sizes and time intervals
(late, on time, early) can be configured
under File -> Setup -> Vehicle
Presentation.
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Alarm
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Function
Access

Alarm sent by the driver to the control center
via the central system.
Activated by the driver
Tools -> Panic Alarm Log

The driver activates the panic alarm by pushing on the
hidden alarm button located by the driver’s place / via
their interface. While the alarm is active, the vehicle’s
position is continuously updated and displayed in a
separate window.
The vehicle itself can update its external signs with "Call
for help" or any requested message.

Setup
You can select the sound you will hear when receiving an
alarm.
1. Disconnect ( ).
2. File -> Setup -> Alarm
3. Select which sound to use.
3.1 Use the default sound by ticking Use system
sound.
3.2 Use your own sound by ticking Use selected
sound file.
3.2.1 Browse to the location of the file on your
computer.
4. Click on the speaker icon to test your sound.
5. Click on Save.

Alarm Window
When a driver triggers the alarm, a red window
appears on all the screens where this plugin is active
and connected to the central system. The audio alarm
is also activated.
The window shows a map with the distressed vehicle
positioned in its center. It provides continuously
updated information about the vehicle number, its
assignment, its position, its speed, its direction and at
what time the alarm was activated. It is also possible
to zoom in and out.
When a user clicks on the Confirm button, the other users receive a confirmation
that the alarm is being handled by someone else and the alarm stops ringing.
The user can also deactivate the alarm in cases where it is a false alarm or an
ongoing test, by clicking on the Deactivate button.
The Alarm window will keep returning, even if it is closed, until an action is taken
by a user.

Panic Alarm Log
The Panic Alarm Log tool lists all logged alarms in the system, including test alarms,
with active time periods and time stamps for each individual alarm update received.
• Filter the table for specific vehicles/
alarms with the free text filter.
• The list can be manually updated
by clicking on the Update button,
next to the timestamp of the last
update.
• Click on a row in the top section
to view a list with each individual
logged (received) alarm update,
including information about who
confirmed/deactivated the alarm,
and when.
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Assignments
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Function

Create, edit or remove
assignments for the vehicles.

Access

Top Tool Window || Tools ->
Assignments

Sections
The assignment plugin consist of four
default sections. *Note that changing the
Menu can also change the default sections.
Functions All tools available for selecting
traffic data and creating assignments, takeover and reinforcements.
Time Controls Time interval, with controls
to move back and forth. It covers both lists.

Assigning a Vehicle to a Block

Other Types of Assignments

There are a few ways to assign a vehicle.
• You can always clear the fields with ESC.
• You can change fields with the tab key.
• You can use the up & down arrows to change rows.

Some systems can have additional types of assignment.
They can be selected via the drop-down menu. You can
assign them vehicles the same ways as described for
blocks, except for Dynamic. Note that they need to be
imported with the planned traffic data to be available.
• Line-Journey: A single journey.
• Planned Reinforcement: Journeys with start time
which can be activated when needed.
• Replacement: Replacing a vehicle with a new route.
E.g., replacing a train with a bus. The stops, route and
timetable will be different than the original.
• On Demand: Journeys with start time which can
be activated when requested by passengers. Shown
as grey with a purple circle when
activated.
• Dynamic: Journey templates with
routes, but no start time, which can be activated with
a given time.

Method 1 || Functions
1. Block number - Type in the number, or click on a
block in the Blocks List.
2. Vehicle number - Type in the number, or click on
a vehicle in the Vehicles List.
3. If needed: Select a specific journey/stop point.
4. Press on Enter to assign, or click on the
assignment button

.

Blocks/Journeys List All planned blocks/
journeys and current assignments
(automatic and manual).
Vehicles List All available vehicles, both
assigned and unassigned. A block graph
can also be shown if needed (right-click the
column headers).
Journey Template Only visible while
selecting Dynamic in the menu. List of all
journey templates, or patterns.

Method 2 || Blocks List
1. Click the vehicle field in the Blocks List to mark it.
2. Type in the number of the vehicle in the vehicle
column.
3. Press on Enter to assign or the Assign button next
to the vehicle number.

Functions
Time Controls

Blocks/Journeys List

Vehicles List
Journey Template

Method 3 || Drag and Drop
Click on the symbol left to a block name, hold the
mouse's left button down, then drag it over the
vehicle column in the Vehicles List.

Dynamic Journeys
Choosing this option will open a third view below Vehicle
List called Journey Template.
Journey templates are journeys without a start time, also
called journey patterns.
1. Select Dynamic in the Menu drop down in Functions.
2. Select a journey pattern in Journey Template.
3. Set the start time in the Starts column.
4. Optional: Add a comment.
5. Optional: Assign a vehicle in the same action.
6. If you skipped 5, you can assign the new Journey in
the Journeys List section with any of the 3 described
assignment methods.

Unlike the other methods, the assignment happens
automatically as soon as you release the mouse
button.
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Reinforcement (unplanned)

Remove Assignments

Use Method 1 up to step 3, then continue with the steps below.
4. Journey field - Select which journey to reinforce.
5. If needed:
• Select a starting stop point.
• Select an ending stop point, else it will end with the
journey.
• Select a time offset, before or after the planned
departure.
6. Click on the Reinforcement button

1. Double-click on a row in the block list to expand it and show the edit fields for every
assigned vehicles.
2. Click on the Remove button

. Note that there is no confirmation dialogue.

Assignment Conflict Notifications

.

From Traffic Studio

Break Block / Take Over
Use Method 1 up to step 3, then continue with the steps below.
4. Journey field - Select the journey for the take over

If you assign a block which already has a vehicle, you will
be warned with a pop-up dialogue.
Click on Approve to overwrite the previous assignment.

5. If needed:
• Select a stop point for the take over.
• Select a stop point to end the assignment, else it will
end with the block.

From the Driver

6. Press on Enter or click on the Assignment button

You will get three options: Approve, Approve at next
journey and Deny. If no decision is taken within 30
seconds, the take over will happen automatically. The
initial driver will also get this choice in their interface.

.

Edit Assignment
You can edit an assignment, add a reinforcement vehicle or an
extra wagon (tramway).
1. Double-click on a row in the block list to expand it and
show the edit fields for every assigned vehicles.
2. Make the needed changes and click on the OK/
reinforcement button to save.
• Note: If you make changes to several vehicles for the same
block, they will each have to be saved.

You will get a notification message in the right bottom of
your Traffic Studio application with the information about
the block and involved vehicles (dark grey background).

Traffic Control Pop-ups
Pop-ups are shown momentarily for 30 seconds in the
lower right corner of the application.
You can choose to navigate through all open pop-ups
(arrows), pin it to the screen (pin), close the current one
(grey cross), or close all of them (red cross).
Clicking on the link will automatically select the
assignment in question in the Assignments tool.
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Couple Tow (Tramway Only)
Method 1 || Functions
1. Block number - Type in the number, or click on a block in the
Blocks List.
2. Vehicle number - Type in the number, or click on a vehicle in
the Vehicles List.
3. Tow number - Type in the number of the tow vehicle in the Tow
field.
4. If needed:
4.1 Select the journey where the tow will be added.
4.2 Select a time/stop point where the tow will be removed.
4.3 Select a time/stop point where the tow will be removed.
5. Click on the Tow button
.
6. The two will be displayed in the Tow column, with a tow symbol
to the left of the vehicle number

.

Method 2 || Vehicles List
1. Click on the row of the tow vehicle to select it in the Vehicles List. The
tow vehicle menu will be visible in the Connected Vehicle column.
2. Select a two vehicle in the drop-down list (all available vehicles are
listed).

3. Couple the tow by clicking on the green button
or press Enter.
4. The two will be displayed in the Blocks List, with a tow symbol to the
left of the tow vehicle number

.

De-couple Tow (Tramway Only)
1. Click on the row to select it, the Remove button will show.
2. Click on the Remove button
to de-couple the towed tram, and
remove it from the current assignment, if applicable.
Note: You can edit an assignment including a towed vehicle just like
other assignments, and that way remove the tow or change towed
vehicle.
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Function
Access

Graphical representation of each block and
its journeys for the day.
Tools -> Planned Traffic -> Block Graph

Access to Shortcut Menus and Planned Traffic
Right-clicking on a block, a specific
journey or a vehicle icon to open the
related shortcut menu(s).

The Block Graph shows the current day's information.
To look at a past of future date, select it in the date field located
in the upper left corner. You can manually enter the date or
select it via the calender. Press on the Update button to load the
relevant data.
You can also use the free text field to filter the results.

Time Slider
Navigate through the day with the blue Time Slider located at the bottom of the Block
Graph tool. You can adjust the displayed time interval between one to four hours, by
dragging the dark grey edges of the Time Slider.

Move to traffic day start
Move backward one hour
Move forward one hour
Move to traffic day end
Center graph around current time, with continuous update

485

Symbols

125

Each row represents a block.
• The yellow number is the line number [485].
• The blue rectangle shows a journey. Its duration, start and
end times are represented by the length of the rectangle.
• The black number in the blue rectangle is the journey
number [125].
• The Vehicle symbol/warning triangle is visible only for
journeys currently running.
• The red vertical line is a visual indicator for the actual
time.

The vehicle symbols represent their deviation from the timetable.
If the symbol is only a yellow triangle , it means that journey
has started, but no vehicle is assigned to it, or reporting.

753

Warning symbols are also shown with the vehicle symbol.
Yellow square: The vehicle is not properly assigned.
Orange square: The vehicle is off route.
Blue square: The vehicle is stuck in a traffic congestion.
Purple rectangle: Manual sign
Red triangle: Active vehicle fault
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Function
Access

Display up to three surveillance cameras
simultaneously.
Tools -> Camera View

• Web camera images are updated every 30 seconds.
• Select a camera for each of the three sections using the
separate drop down camera view menus.
• Camera name, date and time stamp (last update) is
indicated in each section.
• The selected camera in each section is saved between
sessions.

Stop Point Shortcut Menu
• Right-click on a stop point and select Show Camera View:####. Note that this menu
option is only available for stop points configured as being visible from a camera.
• Camera View is opened if it was not already and the corresponding camera view
opens in the top camera view section.
Camera Shortcut Menu
• Right-click on a camera symbol and select Show Camera View:####.
• Camera View is opened if it was not already and the corresponding camera view opens
in the top camera view section.

Select Camera
Click on the camera view menu to open the drop down menu
with all available cameras. Scroll and select camera. The selected
camera image will show immediately.

Notes

Zoom to Camera on Map
Click on the Zoom to camera button in a section to zoom the
Map to this camera. Both location and direction of the camera is
indicated by the symbol.
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Function
Access

Request CCTV uploads from selected vehicles
to the central systems for review/analysis.
Tools -> CCTV Media

• Files might be encrypted. If so, you will need the
correct application and encryption key to view
them.
• Up to 15 vehicles can be selected for simultaneous
media upload.

Sections
The CCTV plugin consist of three default sections.
Request upload CCTV media Select vehicle(s) for the
CCTV files
CCTV upload requests Upload status for the CCTV
files. Once completed, they are moved to the last
section.
Available CCTV files All available files ready for
download via Traffic Studio.

Request upload CCTV media

CCTV upload requests

Retrieving Files from Vehicle(s)
Start in the Request upload CCTV media section.
1. Vehicles: Select up to 15 vehicles. Use the search
field to narrow the list.
2. Start, Duration: Select the date & time and
duration for the files to retrieve.
3. Name: Give it a name. The downloaded files
will be saved in a folder with that name.
Unnamed files will end up in the main filter
without grouping.
4. Comment (optional): Add a description, e.g.,
why the request is made.
5. Click on Upload.
Requests are listed in the CCTV upload requests
section with a progress bar in the Status column and
a descriptive text.
When the upload is done and successful, it will be
moved to the Available CCTV files section.

Downloading Files
You can only download files once their status
shows "Uploaded, Available". These files are listed in
the Available CCTV files section.
1. Select a file by clicking on its row.
2. Click on Download.
3. To quickly access your files, you can click
on "Downloaded files" which will open your
Windows Explorer to the selected row's folder.
From there, you can navigate back to the main CCTV
media folder to easily reach any other downloaded
files.

Available CCTV files
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Function
Access

Real-time list of all charge points and connected vehicles,
with remote control.
Tools -> Charge Points

Main View
A table lists all the available charge points with real-time information
about connected vehicles, their charging status, State of Charge (SoC),
etc. Controls can be enabled to remotely control the selected connector.

Tool Controls
Free Text Field: Type letters and/or numbers to update the table.

Charging Station History
1. Right-click on a connector (map or
table) to open its short-cut menu.
2. Select Show Charging Station
History: ####
3. Select a date and click on Load.

OCPP History
1. Right-click on a connector (map or table) to open its short-cut menu.
2. Select OCCP History: ####
3. Select a date and click on Load.

Status: Filter the status in the drop down menu.
View Mode: Choose between Charge Point, Connector and Power Group.
Details: Open the detail view for a selected connector.
Show on map: When activated, the map will zoom when you select a
row in the list

View Modes

Remote Controls

Charge Point: All the connectors, grouped by charge point.

Start & Stop

Connector: All the connectors.

Click on Start or Stop to control the connector behaviour.
to start the connector.

Power Group: All power groups, with assigned connectors, and current/
max charge in kW and %.
Power Group in Details
Power Groups are used to load balance the chargers so they do not exceed
the set power limit.
To maximize compatibility with different chargers, this function does
not “throttle” the chargers up/down, but simply turns off the “least”
needed charger in the current version of the solution. In other words, it
will turn off the connector connected to the vehicle with the highest SoC.

The command/request is displayed next to the buttons.
Progress indicators below the buttons show “command
sent”. When the command takes effect the indicator is
removed.

Reset
If a charger does not respond to commands, it may have
to be reset. You can select between a soft or a hard reset
(see the charger manufacturer's description of soft/hard
reset functionality).
1. Select a connector by clicking on its row.
2. Click on the Reset button in its Details view.
3. Select Hard or Soft reset. Status text will appear next
to the button along with a progress bar.
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Function
Access

List all past and incoming connections for the current traffic
day with their connection status.
Tools -> Connection Monitor

Main View
A table lists all the past and future connections, with planned and
forecast times for the two involved vehicles as well as the connection
status for each of these connections.
The content can be filtered by types of connection status, companies
and with a free text filter.

Tool Controls
Status: Filter the status in the drop down menu.
Company filter: Narrow the table to specific companies.
Free Text Field: Type letters and/or numbers and the table updates
automatically.
• Click on the Magnifier image before the Search Field to
activate the field for each column. Any information entered in
those new fields will only apply to their own column.
Configuration: Change to the Configuration view where you can set
time intervals and colors for the connections.

If a connection cannot be met because one of the journeys/arrivals/
departures has been canceled, it will be indicated with crossed-out
forecast and timetable times for that vehicle.

Connection Status
No information: The forecasts are missing for at least one vehicle, e.g., one vehicle is not
reporting, a journey has not started yet, etc.
Will likely fail: The connection will likely fail as the margin is too small between
forecasts, walking time and waiting time.
Will fail: The connection will fail as there is no margin between forecasts, walking time
and waiting time.
Will succeed: The connection will succeed as there is a good margin between forecasts,
walking time and waiting time.
Failed: Vehicle A arrived after Vehicle B had already departed the stop.
Succeeded: Vehicle A arrived in time to connect with Vehicle B.

Configuration View
Settings for the time intervals and the status colors. Click on the Settings button

.

To exit the Configuration View, click on Save to keep your modifications or Cancel.
Future timespan: How far ahead the connections are shown, in hh:mm.
Historical timespan: How far back the connections are shown in hh:mm.
Status Colors: Change the colors for each status.
Cancel a Connection
1. Right-click on the connection's row.
2. Select "Cancel Connection" in the shortcut
menu.
3. In the pop-up window, select a reason. You
can also modify the internal description.
4. Click on Save.
How to Change Colors
1. Click on the arrow next to
the color.
2. Select a predefined color or
one of the recent colors.
3. Save.
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Function
Access

List of every planned journeys at the stop,
with forecasts, traffic information, APC, next
passages, etc.
Tools -> Customer support

Sections
Customer support consists of three sections.

Filters

Line

The line of the departing vehicle.

Narrow down the list by combining different filters.
• Text filter, e.g., 3442 for journeys related to
vehicle 3442.
• Stop point filter, e.g., Central Station B, Maple
Park 2.
• Line filter, e.g., only show journeys for line 3.
• Destination filter, e.g., only show journeys for
all lines heading to Maple Park

Destination

The journey destination.

Journey

The journey of the departing vehicle.

Block (optional)

The block of by the departing vehicle.

Stop

The stop point within the area.

Timetable
Arrives

Scheduled arrival time of the vehicle.

Timetable
Departs

Scheduled departure time of the vehicle.

Forecasts
Arrives

Forecast arrival time of the vehicle.

Forecasts
Departs

Forecast departure time of the vehicle.

Departure

Actual, reported departure (historical).

Vehicle

Vehicle number and icon.

Deviation

Time difference between scheduled and
actual departure.

Last Stop

The previous stop visited by the vehicle.

Journey Status

Journey status, e.g. started, in-between.

Status

Timetable (not left yet), Departed (has left).

Passengers

Number of passengers onboard.

Connection
From

Connection information.

Connection To

Connection information.

Selection Search criteria for date and stop area.
Filters The section with free text search, stop point,
line and destination filters.
Stop Status Show timetables, forecasts and other
traffic related information
Filters

Selection
Stop Status

Colour-Coding
• If using Now: The upper part of the table is not
highlighted to show that these journeys have
not yet departed from the stop according to the
timetable. However, the vehicle might be early.
Always check the Status column if in doubts.
• The bottom part of the table is greyed to show
that these journeys should have already left the
stop point according to the timetable. However,
the vehicle might be late. Always check the
Status column if in doubts.
• Blue vehicle icon means a late departure.
• Red vehicle icon means an early departure.
The list updates in real time.

How does it work?

Next Passages: Vehicle #

Start by selecting search criteria in the Selection
section.
1. Select a date. Now is selected by default.
1.1 To choose your own date, uncheck Now.
Enter the date yourself or select it via the
calendar.
2. Select a stop area. Use the free text filter to filter
the list.
3. Click on Search to generate results.

Right-click on a grey row and select the "Next
passage" option.
A new tab will open in the bottom tool window
with all planned passages at this stop point for
the selected vehicle.

You can disable the popup windows
for free texts and/or disturbance.
Start by disconnecting, then go to File
-> Setup -> Customer Support and uncheck the
options.

Tips

You can open multiple tabs for different vehicles.
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Function
Access

List all drivers in the system. User can
add/edit information, and log in/log out
a driver on a vehicle.
Tools -> Drivers

Bottom Tool Window
The Drivers tool lists all drivers, regardless
of status. They are sorted by their employee
numbers.
• Company filter: View drivers from selected
companies
• Drivers Status filter: Focus on active/
inactive or logged in drivers.
• Free text filter: Narrow the list to only
include rows with at least one matching
cell.
• Click on a list row to select it/the driver.
• Press Esc to de-select the row/driver.
• The buttons Add driver and Update driver
will open a new window in the Left Tool
Window. You can also double-click on a
row to open the driver's window in the Left
Tool Window.

Left Tool Window
The Drivers tab in the Left Tool Window contains
the same information as the one in the Bottom
Tool Window, with the addition of a picture.
This is where you can modify a driver’s
information and/or create a new profile.

Employee No.

A unique ID for each employee

First name

Driver’s first name.

Last name

Driver’s last name.

Active

Set active status for the driver (checked box)

Active Status
Changed

Date and time when the active status of the
driver was changed.

Description

Any comment or description

Company

The company the driver belongs to

Vehicle

The vehicle where the driver is currently
logged-in.

Add Driver
1. Click on the Add driver button to open a new
window in the Left Tool Window.
2. Enter all the information. Make sure to give
your driver a unique ID number.
3. Optional: Click on the Browse button to add a
picture and find the file on your computer.
4. Click on the Save button.
Update Driver
1. Select a driver in the Driver window and click
the Update driver button.
2. Make the modifications.
3. Click on the Save button.

Log in Driver
You can remotely log in a driver to a specific vehicle
via the vehicle shortcut menu. Note that the list only
include active drivers who are not logged in to a
vehicle. If you want to move a driver, you must first log
them out (see Log Out Driver).
1. Right-click on the vehicle symbol for the particular
vehicle anywhere in Traffic Studio and select Log
in Driver.
2. The Log in Driver window will open on your
screen. It is similar to the Drivers plugin, filtered
to only active vehicles. The bottom part of the
window is highlighted blue with instructions to
follow.

3. Click on a row to select the driver.
4. Click on the Log in Driver button.

Log Out Driver
There are three ways to log out a driver:
• Drivers Plugin: Select the driver's row and
click on the Log out driver button at the
bottom .
• Drivers Plugin: Right-click on the vehicle cell
to open its shortcut menu and select the Log
out driver function.
• Any vehicle icon, any plugin: Right-click on
the vehicle icon to open its shortcut menu and
select Log out driver.
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Function
Access

Settings view for Event types to active them, modify their triggers
and create aggregated events for drivers.

Tools -> Event Monitor -> Event Configuration

Symbols
There are three colors associated to the event types; blue for
information, yellow and red for severity.
How to activate/edit events
1. Select the company.
2. Click on the event type in the
list to show its settings in the
Edit Configuration Triggers
section underneath the list.
3. Active the event type by
checking its “Is Active” box.
4. Modify the trigger by typing the
new value or using the arrows,
when available.
5. Click on Save to keep the new
changes.
Note that some events do not have
triggers, such as “Buss is full” and
“Interchange failed”, as they are
either true or false.
Note also that only activated event
types are recorded and can be
searched in Event History.

Advanced: Aggregated Events for Driver (A.E.D.)
An A.E.D. groups certain types of events and is recorded when the vehicle/driver
reaches a sum of 100% for those. There are 3 things to consider: the time window,
which events are part of the A.E.D. and their percent weight.
Percent Weight? What’s that?
A.E.D. can be tricky the first few times so let’s have a closer look based on the
screenshot below.
An A.E.D. shows up in Event Monitor only when the sum of all the reported events
reaches 100% within its time window. In our example, as soon as one of the weighted
event happens, the clock starts ticking. If enough events happen to add up to 100%
before the time window runs out, then an A.E.D. will show up in Event Monitor with
the name “Training Test” and that specific instance resets.
If it fails to reach 100% in 25 minutes, then it will forget the very first event and move
to the next one, adjusting its timer accordingly.
E.g., Excessive Idling happened at 10:00. Excessive harsh braking happened at 10.15,
then Excessive Idling happened again at 10.24. By 10.25, which is 25 minutes later,
we have reach 30% + 20% + 30% = 80%, which falls short of 100%. The Training Test
removes the first Excessive Idling, adjusts its sum to 50% (20% + 30%) and the timer’s
start is moved to at 10:15.
Create an Aggregated Events for Driver
1. Select Aggregated Events for Driver in the list.
2. Check the “Is Active” box to enable all instances.
3. Click on the Add button.
4. Enter a name for the new instance.
5. Select a time window. The format is hh:mm:ss.
6. Enter a value for the events you wish to monitor. Note
that the value is in % and needs to be within 0 and
100%, where 0 excludes the event from the instance.
The sum of weights does not have to be 100%
7. Click on Save to save the instance.
Edit an Aggregated Events for Driver
1. Select Aggregated Events for Driver in the list.
2. Select the instance by clicking on it.
3. Make your modifications.
4. Click on Save to keep the changes.
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Function
Access

Real-time list of the events generated by vehicles, stop
points and assignments in the last 24 hours.
Tools -> Event Monitor -> Event Monitor
(Tools -> Event Monitor -> My Events -> ...)

The list updates automatically as soon as events are reported.
We highly recommend that you use filters so that you can focus on the specific
events you want to monitor, else they might get lost amongst everything else. As
long as they are activated in Configuration, even if you filter them away, you will
be able to see them again in both Monitor and History.

New Events
The latest event is added at the top of the table and highlighted in yellow for a
few seconds to catch the attention of the user.
Notify
If Event Monitor is not the focused plugin (orange/grey tab), its tab will change
to yellow to catch your attention.
You can turn on sound notification for every new event. Click on the audio
notification button
sounds.

to activate it, and select one of the three available

Event Filter
Filter the information in the table by event types. A small
counter lets you know how many types are shown, e.g.,
(19/21).
1. Click on the Event Filter drop-down button.
2. Click on the check box to select or deselect its
corresponding event. The table updates automatically.
Search Field
The search field helps to narrow the information and highlights in grey the
cells including the search criteria. Type letters and/or numbers in the field. The
table updates automatically.
In the image below, the filter “35” flags Origin (line 353), Event Description
(block Y135) and Created time (23:35:00).

My Events
You can set up different instances of the Event
Monitor tool, with different filter settings and
notification sounds.
1. Click on the Add/Edit button
2. Enter a name.
3. Save.

.

You can always modify the filters/sound for each instance, Traffic Studio will
remember each change.
Use the Pin button to open your instance(s) when you start a new Traffic Studio
session.
You can find all your instances under Tools -> Event Monitors -> My Events ->
"list of all instances"
To remove an instance, use the Add/Edit button, select it in the Name drop
down, and click on Remove.

Confirmed

Aggregated Events for Driver

You can confirm an event to let other users know that you are handling it.

The Aggregated events for driver is listed with the name of the instance, in this
case “Test”. Its creation date corresponds to the last recorded event.

To confirm an event, click on its check box in the Confirmed column. The time
of the confirmation and your user name will appear next to the ticked check
box. Note that you cannot undo a confirmation.

Click on the row to open up a list of all events included in this specific A.E.D.
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Function
Access

Historical list of the recorded events for a selected period. Heat
Map function available.
Tools -> Event Monitor -> Event History

The events are initially listed chronologically from the most recent to
the oldest.
If you are using the Heat Map, we highly recommend that you use the
filters, else the Heat Map will be more or less meaningless.

Heat Map
The Heat Map graphically visualizes where events have occurred by color-coding
areas according to their concentration of events. The filter options also apply to
the Heat Map, making it possible to focus on the chosen event types, specific lines,
journeys, etc.
The colors range from green, yellow, orange and into red. Green denotes areas with
few reports while red represents areas with the highest amount of reports.
Activate the Heat Map by clicking on the toggle button
at the far right of the
tool bar. Note that this function is turned off by default to improve loading times.

Generate Events
1. Select dates using the Calendars.
2. Click on Search.
3. Optional, combine freely:
3.1 Narrow the results with the Event Filter.
3.2 Narrow the results with the free text filter.

Event Filter
Filter the information in the table by selecting the
events that you find interesting. A small counter lets
you know how many event types are shown, e.g. (2/28).
1. Click on the Event filter drop-down button to open
the list with all available event types.
2. Click on a check box to select or deselect
its corresponding event. The table updates
automatically.

Copy Table Rows to Clipboard
You can select single or multiple rows (standard shift-click/ctrl-click for multiple
selection, copy them (CTRL-C) and then paste them into other applications/
documents (CTRL+V) such as Excel, Word or Notepad.

Excel Export
Click on the Excel export button in the Function Bar to export the current Event
Monitor data to an Excel format. A save dialog will let you name and select a
location for the file.

Search Field
The search field helps to further filter the table.
Type letters and/or numbers in the field. The table updates automatically.
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Function
Access

List of geofences with their attributes. Also show
them on the map.
Tools -> Geofences

Geofences is a tool for viewing geofences, which are virtual
areas with assigned functionality in the system. The
geofences are displayed on the map and are listed in a table
with detailed information.

Overview
• All geofences in your system are presented in a table.
• Click on a geofence to view its details in the details field to the right. The field is
split in 2 parts:
• Upper part shows details of the geofence, e.g. if it's active, if enter/leave are
enabled and when it was last modified.
• Bottom part lists all affected stop points, triggers/thresholds for the geofence,
validity periods, etc.

The geofences types are color-coded, both on the map and in
the list presentation.

Geofence Types
• Coaching zone
: Can be used for monitoring vehicles
entering/exiting the zone, and/or for vehicles driving over
the given speed limit.
• Signal priority zone
: Signal priority zones are used for
triggering traffic signal priority functionality (traffic lights).
These zones also include a geoline, i.e. the vehicle triggers a
priority request when passing the line in a set direction.
• Terminal (multiple stops)
: A geofence area covering
multiple stops placed too close together for reliable
positioning, terminals with varying stop locations or
multiple stop areas with unreliable GPS coverage. The
Terminal area is considered a “one stop” by the system.
• GPS
: This geofence area controls the way the vehicles
report inside the zone. It can most notably be used to define
“water passages”, where buses or trams are loaded onto a
ferry.

• Double-click on a geofence in the table to zoom to it
on the map.
• Right-click on a geofence on the Map and select
“Show geofence details” to select it in the Geofences
tool list, and view its details in the details field.
• Warnings: Visible if traffic data has changed since a
terminal geofence was created, e.g., stop were added/
removed from the area.
• Three filters can be used to narrow both table and map presentation:
• Rules (Geofence types),
• Company
• Free text filter
• Warning
• Specific geofences can also be displayed/hidden to lighten up the map.
Click on the eye icon to display a geofence (default)
or to hide it .

• Road Limitation zone
: This geofence area triggers
driver alerts ahead of road “limitations” like low tunnels,
underpasses or narrow roads.
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Function
Access

List all journey departures. User can modify their starting
time and keep track of who modified them.
Tools -> Journey Start Time

Date: Today's date. To change the date, pick a different one then click Search to
generate the journeys for the new date.
Next Journey Start: Takes you to the row of the next journey starting according
to the current time.

Rows have different colors to indicate
their status.
Orange

Current selection. Click on a row to mark it or on
the button “Next Journey Start” to automatically
select the next starting journey and focus on it.

Yellow

Journey with a modified starting time.

Grey

Tool Controls

Show journeys starting within the next [xx:xx] : sets how far in the future you
want to display journeys in a hh:mm format. The table updates automatically.
Search Field: Type letters and/or numbers in the field to automatically narrow
the table.
• Note that by clicking on the Magnifier image before the Search Field,
you can activate the search function for each column. Any information
entered in those new fields will only apply to their respective column.

Journey which has already departed according to
their planned starting time.

Provided information
The table provides data information about each past and incoming journey.
Block

Journey’s block

Line

Journey's line

Start Stop Point

Journey's first stop point

Destination

The journey’s destination. Will also show any "via
destination" from traffic data.

Journey

Journey's number

Journey Type

Journey’s description, e.g., ordinary, in-between, etc.

Start Time

Journey’s planned starting time, cannot be modified.

New Start Time

Journey’s new starting time, empty unless modified by
the user.

Modified by

User ID of who modified the starting time.

Modified time

Time when the modification was made.

How to Change a Starting Time
1. Click on the New Start Time cell of the journey of your choice.
2. Enter the new time in the hh:mm format and press enter. The row will
turn orange and your user name will show in the “Modified By” column
along with the time when you made the modification.
Note that you cannot modify the starting time of a journey which has already
begun, i.e., is greyed out.
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Function
Access

How long are vehicles considered active?

List all active vehicles by line

A vehicle is considered active and remains in the system for 30
minutes after sending its report. That means that even if the bus
was shut down right after sending its last report, it will show up in
the system for another 30 minutes.

Tools -> Vehicles -> Lines

Use the Interval filter if you want to modify that value only for the
Line tool.

Filter the Selection
You can filter the table with company, interval, free text search and vehicles with
active fault.

Note that 30 minutes is the default value and that it can be
configured for your account, for all tools, under File -> Setup ->
Vehicle Presentation.

Filters and Search
The drop-down filters and check box automatically update the table.

Symbols

Type numbers/text in the search field to update the table and highlight the cells
containing these characters. Click on the magnifier icon to activate a search field
for each column, independent of one another.

The vehicle’s symbols represent their
deviation from the timetable and status.
The colors, sizes and time intervals (late, on
time, early) can be configured under File ->
Setup -> Vehicle Presentation.

Table Content

Tips

The table provides real time information about each vehicle. New information is
updated with a yellow fading background.
You can expand/close any line by using the arrow in the left corner of each line
section. You can also expand/close ALL lines with the arrows located next to the
Company filter.

•
•

Vehicles with the journey status "Between" show the information for the next
journey with an arrow symbol (->) before line, destination and journey. Filter the
table by using "dash" (-), immediately followed by "larger than" (>).

•
•

You can add/remove column by right-clicking on the headers and ticking/unticking
them.

•

You can also sort the list by clicking on the various headers.
Traffic Studio will remember your configurations.

• Sort the table by clicking on the column of your choice.
• Reorder the columns by dragging & dropping their
header where you want them.
A vehicle is considered departed when it leaves a radius of 25
meters around the stop point.
Add/remove columns by right-clicking anywhere on the headers and
unchecking them in the list.
Double-click on a row for the map to zoom in on the vehicle.
An empty folder means that no vehicle are currently assigned on
that specific line.
Are you seeing ??? in one of the columns? That is quite normal. It only
means that you do not have the permission to see this particular
type of information. Unless your job relies on having access to that
knowledge, you can simply ignore it.
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Function
Access

Overview of all/grouped lines and their
active vehicles.
Tools -> Line Overview

Graphic Presentation
Each bar represents one vehicle and its color shows
its deviation from the timetable.
Its size shows how far from the planned time it is,
i.e. the higher it is, the more delayed/late the vehicle
is.

Hide/Show Lines

Notes

You can hide all vehicles on a line by clicking its
number/name. To show them back, click on it
again.
The background of an hidden line is dark grey
and its vehicle section is empty.
Hiding a line affects the other tools and works
like Groups in the Function bar. For example, if
you have Text Messaging, you will not see any
messages sent from vehicles on the hidden line.

The colors and time intervals (late, on time, early)
can be configured under File -> Setup -> Vehicle
Presentation.
Journeys not yet started (gray bars)
The grey bars show vehicles that are assigned to the
line, but are on an empty run or have not started their
next journey (are between journeys). They are shown
this way as to not influence the fleet’s punctuality
times.

Sorting with Line Groups
You can limit the amount of lines being shown by
using Line groups.
You can access the Line group tool in the Function Bar.
Note that sorting by groups in the Function Bar will
influence all the realtime tools in the application.

Tips

• Double-clicking on a bar or
anywhere in the graph area
will open its corresponding line in the
Line Viewer plugin.
• Note that each bar works like a vehicle
symbol. You can access its shortcut
menu by right-clicking on it.
• Each bar also has its own tooltip.
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Function
Access

Graphic representation of a line, its stop
points and all vehicles travelling on the
main routes.
Tools -> Line Viewer or via the
Vehicle Shortcut menu

Symbols | Vehicles
Each arrow represents one vehicle and its color shows
its punctuality.
The end of its tail shows where the vehicle
should be if it were on-time according to the
timetable.
The colors and time intervals (late, on time,
early) can be configured under File -> Setup ->
Vehicle Presentation, Presentation

Line window

Window orientation

You can display the lines with even or
proportional distance between the stop points.
Click on the symbol to get a menu with the two
choices.

The Line views can be shown horizontally or
vertically. To change the orientation, click on the

Show the line in
the Planned Traffic
tool.

Vehicles not on selected route & Block
problems

Symbols | Stop points
Each stop point is shown as a circle. Stop point names
are highlighted in yellow when one vehicle is there.
If there are more than one vehicle, the stop point's
name will be highlighted in orange.

Three buttons become active when the Line views is
open.
Toggle the window orientation between
vertical and horizontal.

in the Function bar.

Even distance mode is represented by a vertical
line while proportional mode is represented by a
broken line.

Each vehicle has a label. Its content can
be configured under File -> Setup -> Vehicle
Presentation, Label.

Function bar

button

This button swaps the
routes.

Vehicles listed under "Vehicles not on selected route"
are not travelling on the main route, which means
they can be at stop points not included in the main
route. When that happens, they are placed in this
section until their route matches the main route,
i.e., they share the same stops and links.
You can find them by displaying their route.

Select a route
To show or hide the
problems on the line, click
on the Problems button.
Possible problems are:
• No assignment for an
active block
• No vehicle reporting to
an active block
• Several vehicles
reporting to the same
active block

Click to open a drop-down list of all routes for
this line direction. The main route is marked by
an asterisk (*) and selected by default. Select any
route to change this view.

Sort the windows numerically, then
alphabetically.
Toggle the even/proportional view for all lines.
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Function
Access

Vector map of the system with
elements of the current traffic.
Tools -> Map

Navigation
Use your mouse to navigate around the map.
Zoom in/out: Scroll the wheel.
Move around: Hold down the left button and
move the mouse around.

Map Tools
The map has useful tools located at its bottom.

Navigation
/

Zoom in / zoom out

Activate the Navigate mode (default mode).
Activate the Select mode where you can
select vehicles or stop points on the map.
Toggle between the two in the drop-down
menu. Select several units at a time by holding
down the shift key.

Map Object Layers
The Map has a layer selection for every
component (vehicles, stop, etc.). Using the
layer buttons, you can toggle on/off their
visibility (left column) and/or their label
(right column), which are turned off as
default.
The Map Object Layers is located in the right
lower corner of the Map.

Symbols
The vehicle symbols represent
their deviation from the timetable.
The colors, sizes and time
intervals in the settings.

Map, follow vehicle
1. Right-click on a vehicle to open its shortcut
menu and select Map - Follow.
2. A new map opens with your vehicle in focus.
The map updates each time the vehicle sends a
new vehicle report or new GPS coordinates.
The followed vehicle has a light grey circle to identify
it as your target, and its label is visible.

The GPS heading is indicated with an
arrow.
Selecting a vehicle will surround it
by an orange halo.
Stop points are shown with colored
dots.
• Normal stop points are blue.
• A selected stop point is orange.

Coordinates
The lower part of the map shows the
coordinates of your mouse pointer or the last
selected vehicle/stop point.

There are multiple types of vehicle icons, such as car,
bus, tramway, train, ferry, snowplow, garbage truck,
etc.

Warning symbols are shown on the vehicle
symbol.
Yellow: Assignment issue.
Orange: The vehicle is off route.

Passenger Counter
Passenger Counters are shown when using Route
Checker and Vehicle History. They appear as an icon
with the latest update of
onboard passengers, how
many passengers boarded
the vehicle and how many
passengers alighted at the
latest stop point.

Blue: The vehicle is stuck in a queue.
Purple: The signs are manually controlled.
Red: The vehicle has an active fault.
Teal: The vehicle is reinforcing a journey.
Green: The vehicle has been paused.

Tips

• You can open as many maps
as you want. They're all
independent of each other.
• Each "following vehicle" map will
have the vehicle ID in its name.
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Function
Access

List information about your displays, including which
stop point(s) each display is configured to cover and its
geographical location when provided.
Tools -> My Displays & Map

Display Shortcut
The display symbols also provides access to the display shortcut menu. Note:
Screenshot and Fault History are only available from Consat system's displays.
For Web and radio displays, these menu choices will be greyed out.

The table lists all the displays in the system, each stop points they
cover and their geographical location. The displays are also shown
on the map.
Filter
The display type filter lets you narrow the table on specific type(s).
Use the free text filter to use keywords or look for something
specific like a stop point. There are three display types:
• Consat displays: Standard at-stop/terminal display
systems
• Web displays: Displays in regular browsers
• Radio displays: Receive forecasts and text
announcements over low bandwidth FM radio.
Note: Only web displays included and configured in the
display data base are included. URL-configured displays are not
included in the presentation.

Show
Right-click on a display and choose
"Show:" to see an image of how the
display looks like. Note that it is a
visualization and not a real screenshot.
Fault History
Right-click on a display and choose
"Show:" to open the display's Fault
History window.

View Selected Display on the Map
Double-click on a row to show this display on the map, and all the stop
points it covers. The map will zoom in on the display symbol. Orange lines
link the display to all stop points included in the display presentation.
Note: Displays without data about geographical position have a grey
square status icon on their display symbol. In theses cases, the position
of the display on the map will be the geographical average of the included
stops.
If you want the map to continually follow the current selection in the
display list, activate the View the
selected display on map-button
by clicking on it
. You can now
scroll through the display list
using the arrow buttons and the
map presentation will follow the
selection.
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Function
Access

List of all available static information
for the vehicles in the system.
Tools -> Vehicles -> My Vehicles

Provided information
The table provides real time information about each vehicle. The column order can be set by dragging and
dropping the columns.
Company

Vehicle Operator/Company

Vehicle

Vehicle number

Type

The vehicle type, presented with the
symbol used in the application and a type
name (bus, tramway, ferry etc.).

System Address

Unique vehicle system address

Node Name

Two Views

Active

The main view is a table listing all vehicles and
their information.

Rakel Address

Rakel radio address

Click on a row to open the detail view. This view
is only available if your system has additional
information outside of those in the main view.

MSISDN

The “phone number” of the vehicle
modem.

Chassis ID

Chassis number.

The contents of this section depends on the
available data, e.g. Emission, Model, Motor,
Number of Seats, etc. Note that information items
presented in the main view may also be included
in the detail view.

External ID

External Vehicle ID number.

Description

This data field shows the origin of the
vehicle data.

Equipped for
Wheel Chair
Transport

(Y/N) Vehicle is equipped for wheel chair
transport.

Audio Information

(Y/N) Vehicle is equipped for audio
information broadcast.

This table can include everything from chassis
ID to Wheel chair capacity to Manufacturing
date. The tool includes a company and a free text
filter for narrowing down the presentation and
functions for sorting the content.

Company and Search
Company uses a drop-down menu to give you the
choice to select a specific company .
The search field lets you input any text or
numbers and automatically updates the content
of the table to highlight the cells containing these
characters. Click on the magnifier icon to enable a
search field for each column, independent of one
another.

Suitable for
Wheel Chairs

(Y/N) Vehicle has room and
is equipped for passengers in
wheelchairs.

Wheel Chair
Places

The number of wheel chair spaces.

Commissioned

The time and date the vehicle was
commissioned.

I4M System Node name.

Manufactured

(Yes/No) If the vehicle is on active duty or
not

The time and date the vehicle was
manufactured.

Modified

The time and date the vehicle was
last modified.

Road Speed
Limiter

Road Speed Limiter threshold
(km/h)

Overspeed Limit

Overspeed threshold (km/h)

RPM Economy
Lower

Lower RPM economy range
threshold

RPM Economy
Upper

Upper RPM economy range
threshold

Over Weight

Over Weight threshold

Harsh
Acceleration

Harsh Acceleration threshold

Harsh Braking

Harsh Braking threshold

Harsh Curving

Harsh Curving threshold

Inclination

Inclination threshold

Fuel Drain

Fuel Drain threshold (l)

Ramp or Lift

(Y/N) Vehicle has ramp/lift for disabled
passengers.

Handicap
Accessible

(Y/N) Handicapped equipped vehicle

Low Entry

(Y/N) Vehicle has low entry doors.

Excess Idling

Excess Idling threshold (s)

Low Floor

(Y/N) Vehicle has low floor.

Seated

The number of passenger seats

Stroller Space

(Y/N) Vehicle has space for stroller

Standing

Toilet

(Y/N) Vehicle is equipped w toilet.

The allowed number of passengers
standing

Visual Information

(Y/N) Vehicle is equipped w information
displays.
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Function
Access

All planned traffic data for a past, present or future calendar
date. The information is shown in a tree structure.
Tools -> Planned Traffic-> Planned Traffic

The content is displayed in a tree structure. Each category has roots (first
name) and subroots (second name). E.g., Blocks & Journeys list all blocks.
When expanded, it shows all the block's journeys.
Each top category as a number within parenthesis to says how many subcomponents it has. E.g., Line 2 (8) has 8 different routes.

Journey
Double-click on a journey to open a new detailed tab in the bottom tool window.
Click once to select a journey and visualize its route on the Map.
In the Journey window, right-click anywhere in the information area to open a
shortcut menu. You can select to see more information about the block containing
the journey, but also which line it services and even its specific route.
There is also a shortcut menu for each row with option to see more information
about the stop point and stop area.

The traffic data shown is for the current calendar day. To look for a different
one, select a calender day (24 hours), then click on the Update button to get
your results.
You can search data via a text field.
You can also draw an area on the map to filter all data geographically. To
activate it, click on the Area Search button, switch the map mode to Select
and draw a rectangle with the left mouse button.
Some views have links to quickly reach other types of information, such as
journeys from a specific route. These links are blue and underlined.

Blocks & Journeys
Blocks & Journeys shows all blocks and their journeys.
Double-click on a block to open a new detailed tab in the bottom tool window.

Lines & Routes
When expanded, each route provides information about its classification (main
route) and type (ordinary, empty, etc.). The number of journeys servicing a specific
route is shown within [brackets] after the its name.
Note that any Empty Runs/In
Between routes are grouped
in their own subcategory
“Empty”.
Double-click on a line to open
its own tab in the bottom tool
window.
Click on the "Display routes"
button
to display all routes
included in the line (black
lines).
Click on a block-journey route
row in the list to select it and
view it on the map highlighted
in orange.
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Routes

Duties (optional)

Select a route to highlight it on the map and zoom to it (grey/blue).

In systems using duties, these are presented in the main list under a
separate Duties section. Expand it and double-click on a duty to open its own
Duty detail window in the Bottom Tool Window.

Double-click on a route to open its own tab in the Bottom Tool Window. It
shows 2 sections; an ordered list of stop points and a list of all journeys
servicing it.
If your system uses navigation hints
and link work action, they will be visible
when you click on a stop point in the list.

Zones (optional)
In systems using zones, these
are presented in the main list
under a separate Zone section.

Stop Areas & Stop Points

Expand it and double-click on a
zone to open its own tab.

Select a stop area to zoom to it on
the map and see it highlighted.
Double-click on a stop area to
open its tab in the Top Tool
Window. It shows connected stop
points, planned traffic, passing
lines, and connections according
to the timetable.

Contracts (optional)
Contracts are “journey groups”
assigned to, and serviced by,
operators. Contracts can be
listed under a separate section
in Planned Traffic.
Expand the node and doubleclick on a contract to view a
detail window with contract
details and a list of all journeys
included in the contract.
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Function
Access

Troubleshooting tool to report a vehicle fault, upload the
diagnostic log and even request a remote restart of the
driver display.

Notes

Vehicle shortcut menu & Assignment -> right-click on a row

This tool lets you report a fault in the vehicle. When you save, your
input is sent forward and a diagnostic log is also uploaded from
the vehicle to the central system for further troubleshooting.
There is also an option to request a restart of the vehicle computer
if needed.

How to Report a Fault
1. Right-click on a vehicle’s symbol to open the shortcut menu
and select Report Fault in the list.
2. The Report Fault tool will open in the Left Tool Window.
3. All fields must be filled with the proper information; complete
e-mail address, phone number and description. Failure to do so
will be flagged in red as a reminder.

• Optional: To restart the driver screen remotely, tick in the
Reboot box below the Fault Description field. The Reboot is an
optional function and not required.
4. Click on Save to begin uploading the diagnostic log from the
vehicle to the central system, as well as initiating the reboot
if applicable. Click on Cancel to close the window without
sending the log/reboot request.
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Function
Access

Lists questions and answers from the preop and post-op checks from the vehicles.
Tools -> Report Sheets -> Report Sheet

The Report Sheets tool shows all pre-op and post-op
checks, along with each questions and their provided
answers.

View (only) Reports Deleted by Driver

Notes

Using a function in the driver interface, the drivers
can cancel or “delete” reports they have sent, if
they change their minds or made a mistake. These
reports will be stored, but not presented in the
regular Report Sheet list.
Check the Deleted box to also view these deleted/
cancelled reports.

The report has 2 modes:
Real-time: Show all reports made in the last 24 hours.

View Content of Selected Report

Historical: Show all reports within the time interval of
your choice.

The expanded reports lists the questions and
answers separately, where each question takes
one row.

All reports made during that period are listed with
checklist type, time stamp, vehicle, driver, etc.

To view the full content of the report, click on the
corresponding row. A new section will open at the
bottom of the table, showing all questions and
corresponding driver answers in the report.

Click on a report list row to view the checklist report
details (entered by the driver) in its own section at the
bottom of the table.

Filter the Report
There are three tools to help you narrowing down your
results.
Free Text Filter
A free text filter allows you to quickly find reports
about any of the available field, such as a particular
address or from a specific vehicle.
Simply enter filter content in the free text filter field
and the list will be immediately filtered to only
include rows with at least one matching cell.
Sheet Filter
This filter contains the available sheet types options.
Category Filter
The report category filter allow you to only include
reports of the categories you are interested in.
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Function
Access

Show externally generated information about
road work, changed speed limits, closed
roads, etc. that may affect the planned traffic
Tools -> Road Situation

Road Situation lists all active/planned road situation
information items, with its own separate map object
layer for all items and a detailed view for the selected
road situation.
• The map shows road situation information that
may be relevant for the lines/routes you are
overseeing/controlling.
• Use the area filter to define and monitor the road
situation within a specific area. The filter you
define is saved for your role/user for the next time
you open the tool.
• Note: Valid weekdays information/multiple valid
periods are shown in the Road Situation Details
window, but not in the Road Situation list.

Table & Map
Road Situation lists road situation information items,
including active period.
Double-click on a row to zoom in on the item on the
map, or click on the “Show Selected” button for the
map to follow the row selection.
All road situation symbols can be toggled on/off via
their own map layer, including their label.

Severity symbol

Filters

Severity: Select the level of severity, ranging from
Highest to Lowest.
Free text filter: Enter text and/or number to filter the
information.

Red: Active road situation, severity
Highest or High
Yellow: Active road situation, severity
Medium, Low or Lowest

Validity: Select between Valid (currently in use) and
Future (planned, but not yet applicable).
Type: Select the type(s) of road situations to monitor,
e.g., accident, animal presence, construction work, etc.

Area Filter
1. Click on the Area Filter button at the right
end of the tab. A new map tab will open.
2. Pan/zoom to the right area.
3. Right-click to draw an area. If you try to
create an impossible shape, the grey area
will turn red. You can always press ESC to
start over.
4. Complete your shape by either bring your
cursor over your first point until your
shape turns green, or pressing Enter.
5. To use a different area, repeat the steps
above. Note that you can only use one Area
Filter at the time.
6. To turn it off, uncheck the Area Filter check
box next to the filters.

Grey: Inactive (future/planned) road
situation
Id

Unique ID for road situation item

Type

The type of disturbance/road situation
information, system-dependent
alternatives.

Location

Street, location description

Description

Descriptive text/content

Start

Timestamp: Time, (date)

End

Timestamp: Time, (date)

Details
Double-click on a row in the table, or right-click on a
road situation icon on the map and select it, to open
its Details view.
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Search Functions

Search Stop Point

Search Street

Search Vehicle
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Function

Locate a stop point in the system by
typing in their name or part of their name.

Access

Tools -> Search Stop Point

How does it work?

Tips

1. Type all or parts of the stop point to update the list automatically
with all the stop points with a name fulfilling at least partially the
search criterion.
2. Add more letters to narrow your search results if necessary.

• Right-click on a stop point to access its
shortcut menu.
• Double-click on a stop point to zoom to it
on the map.

E.g., If you enter ter, you will get a list with stop points such as
Lancaster, Counter, Casterton, Waterloo and Terminal. Add a m (term)
and the list will shrink to Bus Terminal Transfer Point.

Function

Locate a street in the system by typing in
their name or part of their name.

Access

Tools -> Search Street

How does it work?
1. Type all or parts of the street name to update the list automatically. You will
get all the streets with a name fulfilling at least partially the search criterion.
2. Add more letters to narrow your search results if necessary.
E.g., If you enter ron, you will get a list with stop points such as Aaron Place,
Armstrong Road, Cameron Street and Coronation Blvd. Add a t (ront) and the list
will shrink to Front Rd, Frontenac Street and Toronto Street.

Function

Locate a vehicle or a block in the system by
typing in their number or part of their number.

How does it work?
1. Type all or parts of the vehicle number or
block number.
2. Click on the Search button.
You will get all the vehicles, both past and active,
with a number containing or corresponding to
the search criterion.
E.g. If you enter 3 in the vehicle field, you will get
a list with vehicles 3, 53, 333, 613 and every other
vehicle with at least one “3” in its number.

Access

Tools -> Search Vehicle

Active and Historical Vehicles
The results will list both active and
past vehicles (vehicles that have
completed their routes). The vehicles
are sorted according to their last
report.
Each category has a counter showing
how many vehicles are displayed /
total of vehicles. Using the filter will
affect the first number.

Tips
• Do an empty search to get
all vehicles in the system.
All you need to do is to only
click on Search.
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Function
Access

Communication tool between you and the
drivers via text messages.
Via vehicle shortcut menu //
Tools -> Text Messaging -> Send Messages

Send message
Right-click on a vehicle in any of the tools and select the
Send Message to option from its shortcut menu. You can
also click on a message in the Text Message log and click
on Reply.
A new window will open where you can select a predefined
message or type your own. Click on Send to send the
message.
Send to multiple vehicles, vehicles groups, lines
You can use the Map to manually select multiple vehicles
in an geographical area. Use SHIFT or CTRL to add more
vehicles to your initial selection. All those selected (orange)
will show under the sub-category Vehicles and can be
added/removed by clicking on the grey X.
You can also select Vehicle Groups, which can be created
via Tools -> Vehicles -> Vehicle Groups.
You can also send messages to all vehicles currently driving
on specific lines via the Line's drop-down option.

Predefined Messages (Templates)
You can create predefined messages directly in Send Message. Write
down your message and click on the Save as Predefined button.
Note that you can always modify the content and save new
versions. To delete a predefined message, simply click on the X.
Reply Alternatives
You can add reply alternatives to your messages, so the drivers
will only be able to select from these choices when replying.
To add alternatives, type them in the text field and click on the
green + button. Note that you need at least 2 alternatives to be
able to send your message.

Message Log
Message log is found as a tab in the Lower Tool Window. It lists all sent and received
messages. Double-click on a row to open the Message Details view in the right side of
Traffic Studio.
You can acknowledge messages, letting the driver and other traffic controllers know that
you have read the message. You can also sort the list between all messages and only "nonacknowledged" messages.
You can see how many drivers have received a sent message, how many have read and
how many have replied.

Message Details
Message Details opens in the right side of Traffic Studio by either selecting a message and
clicking on the Message Details button, or double-clicking on a message row. It includes
additional information such as a list of all recipients and their read/reply status. If reply
alternatives have been provided, it breaks down the number of answers by alternatives.

Search Text Messages
You can access this via Tools -> Text Messaging -> Search Text Messages.
1. Enter a date in the new window.
2. Click on Search to generate all the messages sent and received on that particular day.
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Shortcut Menu | Journey
Shortcut Menu
Right-click a journey in the Block/Duty Graph, Assignments, or access it
via the Vehicle shortcut menu -> Journey/Next Journey.

Short Run

Short Turn
A short turn is when a vehicle ends a journey prematurely at a specific stop area,
and begins its next journey at the same stop area (usually at the opposite stop point).
It requires that these two consecutive journeys share the same stop area.
You can create a Short Turn by selection the Short Run option from the journey's
shortcut menu. When arriving at step 3, tick the check box. The noticeable
differences will be the pre made internal definition in the popup window, and the
journey/stop point selection shown at step 6 and 7.

A short run is when a journey ends at an earlier
stop point than planned.
1. Journey's short cut menu -> Short Run. This
will open a popup window.
2. Select at which stop area the journey will
end.
3. Check this box only if you want to create a
"Short Turn" from the same stop point. See
the next section for more details.
4. A predefined text is filled for the internal
description. You can modify it.
5. Click on Ok.
5.1 If in Traffic Controller Mode: The task is
automatically created and will show up in
the "To be reviewed" tab of the tool Traffic Tasks.
5.2 Else, the information will be shown in New Traffic Information
where you can modify/add other components before clicking
on Publish. See the section about New Traffic Information for
more details.

Non-Planned Reinforcement (only in Assignments plugin)
Fill in the block and journey fields with the current traffic data information.
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Shortcut Menu | Stop Point
Shortcut Menu
Right-click a stop point symbol or stop point reference, or access it via
the Vehicle shortcut menu -> Last/Next ...

Forecasts
This window shows the information about the lines passing through this
stop point, with actual arrival/departure times and planned time according
to the timetable.
• The vehicle symbols provides access to the standard vehicle shortcuts.
• A free text filter allows you to quickly focus on the needed information.
• Right-click on a row to access the Forecasts History for this specific
journey/vehicle (jid 87259, ... ).

Passing Lines
List of all the lines and destination servicing this stop point.

Traffic Information

History

Show the passenger information for the stop point, i.e. any text
announcement, disturbance and/or audio announcement involving the
selected stop point.

Show all departure and pass-by reports from vehicles traveling by the
stop point.
Click on a column header to sort the information by its content.
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Shortcut Menu | Vehicle
Shortcut Menu
The shortcut menu for vehicles
is accessible by right-clicking
most vehicle symbols or vehicle
reference.

Vehicle Details
This opens both the Vehicle Details view on the right
side of the Main Window, and a new map following
that specific vehicle and showing its planned route in
blue. It can only be opened for one vehicle at a time.
All the Vehicle Details sections can be minimized.
The Vehicle section provides information about the
vehicle (ID, door open/stop button event, direction and
speed), driver, passenger counter, assignment and
deviation from timetable.
Vehicle route show the incoming stop points, with the
vehicle's current position, the distance to the next stop,
and both planned and estimated departure time from
that stop point. A progress bar shows how far along the
route the vehicle has travelled.
Nearby vehicles and Nearby stops list all vehicles/
stop points within 2 km, along with their position in
regards to the selected vehicle.

Block Viewer
Show all the planned journeys
in the block with their start/
end times and destination.
Click on a journey to show all
its stop points and planned
times in the lower section.

Vehicle Signals provides current information about the
vehicle, e.g., fuel, weight per axle, battery voltage, State
of Charge (SoC), temperatures, etc. The information
shown here depends on the data received from the
vehicle.
Note that Node information is only available to super
and power users.
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Shortcut Menu | Vehicle - Vehicle History
Function
Access

List all vehicle reports with comprehensive information.
Draw the vehicle's logged trail on the map.
Via vehicle shortcut menu & Tools -> Vehicle
History

The Vehicle History table is a sortable list of all reported vehicle reports for up to 4
hours. The trails on the map match the data shown in the table.
Change Date & Time
Use the date field to change date and/or time, then click on Update to fetch the
data. Adjust the time span from 1 minute to 4 hours with the blue slider.
Double-click on a row to zoom to it and mark it on the map.
Toggle the button

to get the row's Signals & Metadata information.

If the Follow button
is activated, selecting a row will automatically move the
focus of the map to the recorded event.
Filter
Use the free text filter to narrow down the list to everything matching a specific
string of letters and/or numbers. You can also use the Event Filter which
contains all reported types of events in your selection.

Vehicle Trail
Opening the history of a vehicle also displays its trail on the map. It
also shows all its reports as small dots with the GPS-orientation arrow
inside. Any gap between reports is shown as a dashed line.

Vehicles
You can display up to 3 different vehicles at the same time, in the same window.
Each will have its own color to tell them apart on the map and in the table.
You can add a vehicle in two ways:
1. Via the Vehicle shortcut menu and select the option "Add vehicle to History:
xxxx".
2. Use the drop-down menu in the top row of the Vehicle History to find your
vehicle, then tick its box.
To remove a vehicle from Vehicle History, click on the X next to its "symbolname-colour".
Each vehicle can have its own color, which applies to both its rows in the table
and its trail on the map.
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Station Manager
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Function
Access

All past and future journeys arrivals and departures at a stop
point area. You can reassign the vehicle to different gates.
Tools -> Station Manager

Table Description
Rows have different colors to indicate their status.
Orange

Current selection. Click on a row to mark it or click
on the button “Now” to automatically select the next
starting journey and focus on it.

Yellow

Journey with a modified arrival gate.

Grey

Journey which has already departed according to their
planned starting time.

Block

Journey’s block

Line

Journey's line

Journey

Journey's number

Destination

The journey’s destination. Will also show any "via
destination" from traffic data.

Arrival

Journey’s planned time of arrival.

Departure

Journey’s planned time of departure.

Gate

Journey’s gate according to planned data.

New Gate

Journey’s new gate, modified by user.

Modified by

Name of the user who modified the gate.

Modified Time

Time when the modification was made.

Tool Controls
Stop Area: The first stop area in the list is automatically select by alphabetic
order. Click on the arrow to open the drop down list and pick another one.
Date: Today's date. To change the date, pick a different one then click Search
to generate the journeys for the new date.
Next Journey Start: Takes you to the row of the next journey starting
according to the current time.
Search Field: Type letters and/or numbers in the field to automatically narrow
the table.
• Note that by clicking on the Magnifier image before the Search Field,
you can activate the search function for each column. Any information
entered in those new fields will only apply to their respective column.
(now): Click on Now to move the selection row to the next planned journey
in the table according to the current time.

How to Change a Gate
1. Find your journey and click on the New Start Time cell in the same row.
2. Select the new gate in the drop down list. The row will turn orange and your
user name will show in the “Modified By” column along with the time when
you made the modification.
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Traffic Data Importer
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Function
Access

Import, verify and deploy traffic data to the Consat
Telematics System.
Tools -> Traffic data importer

Log File Tab
The Log File tab provides access to a number of log files, usually used by advanced users
for troubleshooting. Contact Consat Telematics for the description of these log files.

The import process is divided into three stages: Import, Verify and
Deploy. It can be done manually or automatically.
Logs Tab
Logs are available for previous imports.
• Access the current log from an ongoing import stage by clicking
on the log button.
• An overview status is located to the right in every log field and
shows the individual stage progress for the particular data set.
• Problems of the same type are grouped for a simpler overview.
Expand each group to view all these problems.

Logs Severity Symbols
These symbols indicates the level of severity of the recorded log entry.
Information: No error or warnings in the log.
Warning: The log contains a warning. There are three types of warnings:
• Assignment removed (block)
• Overlapping journeys
• Missing destination
Critical error: The log contains a critical error, the process is interrupted.
The errors and their descriptions are taken from Windows’ own error handler.
Critical Error During Upload
Critical errors interrupt the upload. The progress bar will turn red and the log button will
show a red warning icon. Go to the Logs tab for more details about the cause of the critical
error(s).
Manual Restart of the Upload upon Critical Error

Import Stage
Symbols
Import
Verify
Deploy

Overview Status
Completed step without issue
Completed step with warning(s)
Failed step due to critical error.
The process is stopped.

A temporary communication issue can be the cause of a failed upload, which leads to a
critical error. In this case, try to start the upload manually.
1. Go to the Logs tab to look the reason for the interruption and failure of the upload.
2. Fix the issue.
3. Start the import again.
Critical Error During Deployment
• A critical error will interrupt the upload or the deployment of traffic data.
• A red warning symbol will show up on the log button and the progress bar will turn red.
• Such an error is unusual, but if it happens, you should contact your support.
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Traffic Data Importer
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Manual Import - Tab

Step 3: Deploy Traffic Data

Step 1: Import Traffic Data

The top area of the third step shows information about the data
set of the latest upload.

Import
The import begins whenever you start it, either manually or according
to schedule, as long as it is not already in progress. Step 1 and/or 2
might not be available depending on your configurations.
1. * Select the data source.
2. * Select the time period.
3. Option: Enable the mandatory
verification by ticking the check box.
4. Check "Overwrite data in use" when
data must be modified immediately.
Note that doing so can lead to parts of
the system to be out of synch for a period.
5. Click on the arrow button Import Traffic Data.
Import Progress
The progress is shown with a progress bar, with the elapsed and the
estimated remaining times.
• Click on the red cross button to cancel the import.
• Click on the blue information button to check the import’s log.

Step 2: Verify Traffic Data
The top area of the second step shows
information about the import's data set.
• No Mandatory Verification
The process continues automatically
by uploading the traffic data and then
moving to Step 3.
• With Mandatory Verification
The process pauses until you click on
Deny or Accept. You can use Planned
Traffic and Block Graph to verify that the traffic data is
consistent with the planned traffic.
Deny: The process resets back to Step 1.
Approve: The process moves on to upload the traffic data and is shown
with a progress bar, with the elapsed and the estimated remaining
times. Note that you cannot interrupt the upload.

Once the traffic data is uploaded, click on Deny or Accept to
deploy the data. There is no popup window asking you to confirm
your choice.
Deny: The process resets back to Step 1 where you need to import
new data.
Approve: The process moves on to deploy the traffic data. It is shown with a progress bar,
with the elapsed and the estimated remaining times. Note that you cannot interrupt the
deployment.

Automatic/Scheduled Import - Tab
The third tab is where you can configure the process to be automatic, according to a
schedule of your choosing. Note that while the import happens daily, the deployment
happens only during the selected days under Deploy.
Step 1: Import Traffic Data
Enable the automatic process by ticking the check box, then select the time period for the
data and the scheduled time for the import.
Step 2: Verify Traffic Data
If automatic, the process
continues on its own.
If manual, it stops the
process and requires you to
complete Steps 2 and 3 in
the Import Tab.
Thresholds are used to stop
the import or to exclude
data from it, based on the % difference between the newly imported traffic data and
the latest deployed traffic data. If data is excluded for one operator and the deployment
process goes through, the specific operator will continue using the previous deployed
traffic data while the other operators will have the newly deployed traffic data.
Step 3: Deploy Traffic Data
This option is only available if Verify is also automatic. However, it can be done manually
by deactivating the scheduled deployment.
Deployment can be done during one or multiple days. It happens immediately after Steps
1 and 2 are automatically completed.
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Traffic Deviations
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Function
Access

Show driven journeys with traffic
deviations and the reason behind it.
Tools -> Report Sheet -> Traffic
Deviations

Traffic Deviations is built on deviation reports from the
vehicle.
When a deviation report is triggered in the vehicle, the
driver is prompted to explain the deviation by selecting
one of a predefined set of causes. There can be multiple
monitored situations, such as journey incomplete, late
start, journey not driven, etc.
All provided causes can be modified by the traffic
controller at any time.

Filter the Report List

Free text filter

Traffic Deviations

The free text filter can be used to narrow the list
of reports to a specific vehicle, a certain address, a
particular street, etc.

There are currently four supported types of
traffic deviations.
• Late departure (more than 15 min. late).
• Early journey start (more than 5 min.
early).
• Late journey start (more than 5 min. late).
• Incomplete journey.

The list will be immediately filtered to only include
rows with at least one matching cell. Click on the
magnifying glass button to open a filter specific to
each column.
The number to the right of the free text filter show
how many reports are displayed out of the total
number of reports (the numbers will differ only if
you are using a form of filter).

Time Interval: Real-Time and Historical
Modes

Narrow your selection with filters:
• Time interval,
• Deviation Type filter,
• Cause Filter,
• Free text filter.

The Traffic Deviations tool has two view modes:
• Real-time: Show all cause reports from the
latest 24 hours. The table updates in real-time
every time a new report comes in.
• Historical: You can manually select the time
interval to list all the cause reports during that
period.

Time Interval

Check the Now box to use the Real-time mode.

Check "now" to show the latest 24 hours, or select your
own time interval with the from-to calenders.

Uncheck the Now box to select your own time
interval, then click on Search to generate the table.

Causes
Examples of possible causes:
• Road conditions
• Technical faults on the vehicle
• Delay from the previous journey
• Waiting for Interchange
• Accident
• Passenger support
• Staff shortage
• Other

Deviation Type Filter
Display specific deviation types. A counter tells you how
many deviation types are currently used, e.g., (2/3).

Notes

Cause Filter
Display specific causes provided by the driver/traffic
controller. A counter tells you how many reasons are
currently used, e.g., (4/8).
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Traffic Tasks

4
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Function
Access

Display past, current and future
traffic information tasks.
Tools -> Traffic Tasks & via
Function Bar

Types of Information
Disturbance: Forecasts will be cancelled for one or
many information points.

History: The tab
opens a popup with
many search options
where you can pick
the time interval, the
type of information,
stop areas, author,
etc.

Text Announcement: A text message.
Audio Announcement: An audio announcement that
can be recorded or created via Text-to-Speech.
Directions: A simple “drawn” line/graph on the map
showing an assigned/recommended route.

The columns provide information about the type of
information, its internal description, its duration,
its validity, who created it, its priority level and
which information points are affected (vehicles,
stops, lines, blocks).

Information Task Details
Clicking on a row opens a section below with
detailed information about the task. That
information is separated into the individual task
components (disturbance, text announcement
and audio announcement).
Note: several text announcement alternatives will
be presented on separate rows.

Validity

Shortcut menu

Color coded icon showing the validity status
of the information task.

Right-clicking on a row to open the shortcut
menu specific to Traffic Tasks.

Valid (currently active)
Future (not yet active)
Historical (no longer active)

Five validity tabs

To be reviewed: Tasks in need of approval, e.g.,
short run for journeys. This tab is visible for
system with "Traffic Controller" mode.
Valid: Tasks currently active.

Edit (Show if the task needs reviewal)
Opens the selected entry in the New Traffic Tasks
tab in the Left Tool Window.
1. Click on a row to select the information
entry.
2. Right-click to open the shortcut menu.
3. Select Edit.
See the Traffic Tasks - New section for how to
edit and save your task.

Remove
Immediately removes and deactivates the selected task.
1. Click on a row to select the information entry.
2. Right-click to open the shortcut menu.
3. Select Remove.
Copy to New
It can be easier to create a new task by copying an
existing one.
1. Click on a row to select the information entry.
2. Select Copy to New.
3. The task will open in New Traffic Tasks where you
can modify it and save it as a new
one.
Mark on Map
Marks all related locations for this
specific task on the map with an
INFO symbol.
To activate the symbols, right-click
on the row and select Mark on map.
Clear all marks on map
1. To remove the INFO symbols, right-click on any
row.
2. Select the option Clear all marks on map.
Show Related Traffic Tasks
When information tasks are cloned and edited it may be
useful to be able to view the history of a task.
1. Right-click on any row.
2. Select Show Related Traffic Tasks. A new tab opens
showing the selected task and all its previous
versions. Close the tab by clicking on the “X” button
in its upper right corner.

All: Current, future and past tasks within the last
24 hours.
Future: Tasks which are planned but not yet
active.
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Traffic Tasks - New
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Function
Access

Create/edit traffic information tasks
to inform passengers, drivers, etc.
Tools -> New Traffic Tasks
& via Function Bar

1. Types of Information

4. Communication Channels (option)
Selection of broadcast channels for text/audio
announcements.
Click on

(text)

else click on

(audio) to select the channel,

(text)

(audio) to remove it.

Disturbance: Forecasts will be cancelled for one
or many information points.

5. Types of information

Text Announcement: A text message.

5.1 Disturbance

Audio Announcement: An audio announcement
that can be recorded or created via Text-toSpeech.

Turn off forecasts for the selected traffic data nodes
(stops, blocks, journeys, lines, routes, etc.).

Directions: A “drawn” line/graph on the map
showing an assigned/recommended route.

2. Internal Description (optional)
An internal description/comment to the task,
only visible by other Traffic Studio users.

Remember to add an internal description as an
explanation/reminder if there are no text/audio
announcements.
5.2 Text announcement
Use a predefined template or write your own.
Enter an optional header in the separate header field.
This header can be used by web travel planners, etc.
You can use Text Variables which will automatically
be replaced with your own selection. Right-click in the
text field to bring up the four options: lines, lines with
destination, stop areas, and stop points.

3. Valid: Time
Select the starting time and duration of the
task. You can always edit it later on.
Valid From,
Now

When the traffic task will start.

Valid To,
Day End,
Indefinite

When the traffic task will end.

Priority

Label the issue for internal sorting
and organizational purposes, and for
prioritizing selected announcement
in some external (PA) systems.

3.a Valid Intervals (optional):
Choose which days and/or times the traffic
task is active for each type of information,
independently of one another.

Different text announcements for different channels
(option)
1. Write your first announcement in tab 1.
2. Click on the button
to the right of tab 1 to create
tab 2 with a copy of the message and a list of
channels below the text field.
3. Change the text message for the new variation.
Activate the communication channel(s) for this
tab with the green checker buttons. You can only
have one message per channel, but you can have
several channels for one message.
4. Add more variations if needed.
5. Delete a variation by clicking on the tab's X next
to its number.

5.3 Audio Announcement - Recording
1. Click on
to begin the recording.
2. Click on
to end the recording.
3. Click on
to play the recording.
4. Enter the rest of the information like the number
of repetitions, the minutes in between each
broadcast and the volume level.
Audio Announcement - Text to Speech
1. Enter the message in the text field below Audio
Announcement.
2. Click on
to convert the text to an audio file.
You can play the converted audio announcement
using the Play and Stop controls.
3. Enter the rest of the information like the number
of repetitions, the minutes in between each
broadcast and the volume level.
Audio Announcement - Pre-Recorded File
1. Move/save your audio file to your template folder.
2. Click on the hamburger menu icon
the file in the list.
3. Enter the rest of
the information
like the number
of repetitions, the
minutes in between
each broadcast and
the volume level.

and select

Note: Tab 1 will automatically select the channels
that are not covered by the other tabs.
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5.4 Directions
1. Click on the Add button
to open a Edit
Directions map window.
2. Draw your directions line by right-clicking a
series of waypoints, from start to finish. The
final route will display driving direction.
• If you make an error, press Esc to start over.
3. When you are finished, press Enter to save
directions and close the Edit Direction
window. The graph will show in grey with
driving direction arrows on the regular map.
4. The Directions section now reads as Driver
Directions. Note that you can only have one
Direction by traffic task.

6. Traffic Data Selection

Select on the Map

List of all available selection nodes for your traffic tasks.

You can select stop points directly on the Map.
1. Activate the Selection mode in the Map.
2. Hold down the right mouse button to select
stop(s) by drawing a rectangle over it/them.
3. Hold shift if you wish to add more stop(s)
while drawing new rectangles.

Line group

Optional, filter the traffic data by Line Group.

Calendar
day

Select the traffic data calendar day (current day is the
default selection).

Free text

Type in numbers/text to view matching first-level
nodes. Multiple entries can be entered with a comma.

(area)

Draw an area on the map to only include related nodes.

(zoom)

Zoom to the drawn area above.

Show
Empty Run

Check/uncheck box to show/hide empty runs.

Selection Categories
You can select any combination of the following nodes.
Some nodes can be expanded into many sub-categories.
Note that some selections can overlap.
• Line-Journey: Line -> Journey -> Departure
• Lines: Line -> Line w. destination -> Main Route ->
Stop + Other Stops -> Stop
• Blocks: Block -> Journey -> Departure
• Stop Areas: Stop area -> Stop

Open Edit Directions.
Remove the Driver Directions from the task.
On the map, zoom to the drawn route.

Another way to look at them, to help your selection, is
what they cover and if they are tied to timetables or not.
• Line-Journey: Assignments - tied to timetables
• Lines: Geography - not related to timetables
• Blocks: Assignments - tied to timetables
• Stop Areas: Geography - not related to timetables
A ticked box in the tree indicates that this node and all
underlying nodes will be affected by the announcement.
A filled box means that the related node is only partially
affected as not all the underlying nodes have been selected.

Make Selection Valid for...
To make a selection for specific line(s)/
journey(s), into a selection for all lines passing
affected stop points, click on Make selection
valid for all lines.
To make a selection for specific stop(s), into a
selection for all affected lines, click on Make
selection valid for passing lines.

7. Save and Publish
Click on the Preview button
below
the Information Points section to open a
new window showing all the details of your
information task, including the selection.
Review the various parts. When satisfied, click
on Save and your task will be added to the
system.

You can double-check your selections by clicking on
Preview Selection located under the list.
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8. Templates

Tips & Tricks

You can create and use templates to fill in various
steps above. You can combine multiple steps, e.g.,
text announcement and traffic data selection.

Texts: When creating a text announcement
and/or a text template, remember that you
can use the Text Variables by right-clicking in
the text field.

Templates are available on a separate expandable
section in the upper left side of Traffic Information,
with its own free text filter, sorted in categories.
Only super users can create/edit templates.
Select a Template
1. Browse through the list and/or use the text
filter to find categories.
2. Click on the category/sub-category to select it
and display all its templates in the area below.
A summary of its component(s) is shown in the
right column with icons corresponding to the
information types.
3. Click on a template to select
it.
4. Double-click the template
row, or click on the Use
button, to load the selected
template's content into the
respective sections of New
Traffic Tasks.
• You can repeat this step for
additional template, e.g.,
combining a template for
text announcement and
a template for selection
nodes.
5. Verify the task content and
make any needed changes
or additions before you
publish the new task.

Selection: Picking the right selection category
can be a little confusing sometimes, but it's
all about what you want to affect.
E.g., You want to remove forecasts and add a
text message at the stop point "Guy Street".
Do you want to affect ...
1. ... only a specific journey?
1.1 Use Line-Journey.
1.2 Find your line and expand it.
1.3 Find your journey and expand it.
1.4 Check the box next to Guy Street.
1.5 Repeat for any additional journey.
2. ... only a specific line?
2.1 Use Lines.
2.2 Find your line and expand it.
2.3 Expand the right direction.
2.4 Expand Main Route (unless it's a stop
not usually on it).
2.5 Check the box next Guy Street.
2.6 Repeat for the other direction if that
applies, or for more lines.
3. ... all lines?
3.1 Use Stop Areas.
3.2 Find Guy Street. You can use the text
filter to quickly narrow the list to it.
3.3 Expand it if you use stop areas to
select the right direction. Check the
box of the stop point(s) or the whole
stop area.

1

2

3
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Traffic Status
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Function
Access

A real-time dashboard highlighting
traffic and servicing problems.
Tools -> Traffic Status

Show on new map

Sections in Details

Click on this button to open a new map tab showing
only the vehicles in this specific section, e.g., a new map
showing only early vehicles.

Deviations
Two sections for vehicles with early or late
deviation from the timetable.

Sections

Connections Status

Each section is independent with its own filters.
They can be hidden and repositioned.

This section shows the connections which have
a risk of failing. It is limited to two connection
status:

Early vehicles

Vehicles in
queue

Late vehicles

Vehicles with
active fault(s)

Connection
issues

State of Charge

Vehicles off
route

Passenger
Occupancy

Vehicles with
assignment
issues

Dynamic
Journeys

Filters
Each section has its own filters, with at least a Line
Filter and free text filter.

Reposition Sections
Click and hold the mouse button down on the section
header to drag and drop it wherever you want in the
whole list.
You can also click on the Setting Icon at the top right
to show arrows for each section, which you can then
use to move up or down the different sections.

Will probably fail

•

Will fail

Warning Status
• Off Route: all vehicles not following their
planned route
• Assignment: all vehicles with assignment
problem
• Queue: all vehicles stuck in a queue
• Active Faults: all vehicle with an active fault

Adjustable Height

Information & Warning

Drag up/down the splitter bar to change the height of
each section (3 dark dots on white background). Each
section also has its own scrollbar.

Some sections can be set to show all vehicles by
setting the filter to the max.
• SoC: Set the filter "up to" to 100%.
• Passenger: Set the filter ">" to 0%.
• State of Charge: all electrical/hybrid vehicles
with a low battery
• Passenger Occupancy: vehicles with
passenger counters and available
information about passenger capacity.
• Vehicles whose drivers have selected "full
bus" in their interface are listed as 200%.
• 100% occupancy: # of passengers onboard
= # of seats.
• 200%: # of passengers onboard = # of seat
+ # of standing places.
• Dynamic Journeys: vehicles servicing a
dynamic journey (created from journey
template or pattern).

The total amount of results is shown at the end of
the filter row, and will adjust to your filtering.

Show/Hide Sections
Use the buttons in the top row to show/hide the
related sections. A dark grey button means the
section is visible, while light grey indicates that the
section is hidden.

•

Tips
• Right-click on any header within a section
to add/remove columns, e.g., journey
progress, SoC, passenger occupancy, etc.
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Vehicle Fault History
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Function
Access

List of current/active faults and cleared (historical) faults,
reported by the vehicle or display.
Vehicle / display shortcut menu -> Show fault history for

Active Fault Status Icon (Vehicles only)
In systems with the fault service active, all vehicles
with active faults are displayed with an active fault
status icon, a red triangle with an exclamation point.

Columns
Synopsis

Fault “Name”/Synopsis for quick identification.

Severity

The severity of the fault, including the status “cleared”, meaning that the
fault instance is no longer active.

Time

The time and date when the fault was triggered (in the vehicle system).

Description

The fault description text, as reported by the fault management system. This
is usually an easy to read description of the problem.

Id

The unique fault Id.

Find Vehicles with Active Faults
To find vehicles with active faults, you can use:
• Active Vehicles. Check the “Active faults only” filter check box next to the
free text filter to filter the list.
• Traffic Status. Look at the section Warning Status | Active Faults.

Notes

Overview
The popup lists all active fault codes. Use any of the
three filters to narrow the list.
• The free text filter lets you view only rows with
at least one cell with matching content.
• Check the inactive filter check box to view all
faults, including cleared (inactive) faults.
• The Severity filter allows you to view only
faults with selected severity levels. Check the
boxes of the severity levels you want to include.
Tick the "inactive" box to also list the inactive active
faults, i.e., those which have been resolved.
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Vehicle Groups
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Function
Access

Management tool for vehicle groups. They can be used in
the Voice Communication and Text Messaging tools.
Vehicles -> Vehicle Groups

Sections
• Vehicle Groups (left): List of all current vehicle groups. Can
create and delete groups.
• Group Details (right): Editable fields for the selected (or new)
vehicle group.
Search
The search fields filter the data displayed in their own list. Every
cell matching the filter content is highlighted in grey to make them
easier to notice. Only the rows with matching cells are included in
the list.
The list is automatically updated as you enter information in the
filter field.

Create a Vehicle Group
1. Click on the New button.
2. Enter the information under Group Details,
such as Name and Description (optional).
3. Select the group’s company via the drop-down
menu to generate the list of Available Vehicles
list to the right. Note that once the group is
saved, the company selection will be locked.
4. Select the vehicles in the Available Vehicles list
to the right.
• Double-click on a vehicle or select a vehicle then click the upper arrow
.
• Select multiple vehicles at the same time by using SHIFT and/or CTRL when
selecting vehicles, then click on the upper arrow
.
• Remove vehicle(s) from the Selected Vehicles list by double-clicking on a
vehicle, or selecting it and clicking on the bottom arrow
.
5. Click on Save to save your group. The orange row will update with the group
information.

Edit a vehicle group
1. Select a group in the Vehicle Groups list. Its properties automatically appear
in the Group Details window. Note that you cannot modify its company.
2. Modify the name, description and/or the vehicles selection.
3. Click on Save to keep the changes.

Delete a vehicle group
1. Select a group in the Vehicle Groups list. Its properties automatically appear
in the Group Details window.
2. Click on Delete to remove it from the list. Note that you will not be asked to
confirm the deletion, nor can you undo it.
Notes
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Function
Access

Manage voice calls, messaging and
alarm with the drivers.

Responsibility/Forwarding (option)

Commands

Tools -> Voice Communication
-> Voice Communication

In the responsibility field, all responsibility areas/control
centers are listed with symbols showing their responsibility
status. The name of your command center is displayed at
the top left of the responsibility field.

These buttons mirror the basic command
keys.

Sections & popup
Call Queue: All call requests sorted in order of their
priority level and time stamp.
Responsibility: Optional, for shared responsibility
between traffic centers, forward to hand units, etc.
Selection & Details: Select who to call, which then
shows details about that unit during the call.
Command Field: View entered key commands.

All areas have a red status if no one has taken their
responsibility.
Note! Call requests/messages to the areas with no
designated responsibility will be forwarded to a preconfigured unit.
Someone has taken responsibility for the area

Responsibility status unknown/not functional – database
connection not established.

Communication: Volume level, signal’s strength
and current communication status.

Responsibility for area forwarded to (hand) radio unit

Alarm

Call Queue

Responsibility /
Forwarding
Selection &
Details
Commands

Information
Queue

Communication

Call Group. Same as Home.
Call. Same as +.
End Call. Same as -.

No one has taken responsibility for the area

Information Queue: All messages and alarms from
drivers.

Alarm: Incoming alarms open in a pop
window at all the stations equipped with Voice
Communication.

Send Messages. Same as F10.

Responsibility: Accept for one or many areas
1. Click in the corresponding check box.
2. In the confirmation dialog shown, click Yes
3. When your responsibility is established by the central
system, the status indicator will switch to show a green
dot symbol.

Mobile & QR Code
Use your mobile phone to make calls
through Traffic Studio.
Open the CTS PTC app and scan the QR code
that appears when starting Traffic Studio.
You can always bring it up by clicking on the
phone icon in the Commands section.

Responsibility: Forward Incoming Call Requests/Information
Messages
In cases where you must leave your workstation, you might
need to forward incoming messages to a (pre-configured)
radio unit.
To forward the calls to an area, select a unit in the Forward
drop-down menu, then confirm your choice.
The status symbols for the areas you have responsibility will
change to show the forwarding symbol(s). While the calls are
forwarded, all incoming messages and calls in the queue lines
will be greyed out.
When you return to your workstation, select “Not Forwarded”
in the menu to stop forwarding the incoming call requests/
messages.
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Voice Communication
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Call the Top Vehicle/Group in the Call Queue

Call (the vehicle servicing) a Block

New Message

The Call Queue is usually in focus so you can quickly
answer with the command keys.

Click on the row’s Call button
or:
1. Press + (Call).
2. Press Del (block) to filter/select block. All
available blocks (and their servicing vehicles)
are listed in the Selection & Details field.
3. Enter the block number to filter the list or
select it with the mouse. Navigate with the
up and down arrows to make your selection.
Blocks without vehicles cannot be selected.
4. Double-click on the row or press Enter.
5. Talk.

This tool is used to send simple text messages or
codes corresponding to messages in the recipient’s
radio unit.
1. Select the vehicle/unit in the Call Queue or the
Information Queue and press F10 (Text message).
• OR go to Tools -> Voice Communication -> New
Message, then enter the number of the receiver.
2. Select the type of message.
• Text: Simple text message
• Flash: Text message + blinking light on the
receiver’s unit.
• Status (Network dependent): Send a code
generating a predefined message in the receiver’s
unit.
3. Select a predefined message or write your own.
4. Press Send.

Click on the top row’s Call button , or:
1. Press +, (Call).
2. Press Enter (Execute) to start the call.
3. Talk.
Remove the Top Call Request (without calling)
or press F6.

Click on the top row’s delete button

Calling any vehicle/unit in the Call Queue
Click on the row’s Call button , or:
1. Click on the row to select it.
2. Press +, (Call).
3. Press Enter (Execute) to start the call.
4. Talk.
Remove any Call Request (without calling)
Click on the row’s delete button
1. Click on the row to select it.
2. Press F6.

or:

Remove the Top Information Message
Click on the top row’s delete button

or press F5.

Remove any Information Message
Click on the row’s delete button

.

Directly Call a Vehicle/Unit
1. Press + (Call), or use the Call button .
Available vehicles/units are listed in the Details
field.
2. Enter the vehicle/unit number or select a
row with the mouse. To filter the list, press
/ for vehicles or * for units, then enter their
numbers.
3. Double-click on the row or press Enter.
4. Talk.

Call a Hand Unit (radio)
Click on the row’s Call button
or:
1. Press END (Call Hand Unit). Available hand
units are listed in the Details field.
2. Enter the call number to filter the list or select
it with the mouse. Navigate with the up and
down arrows to make your selection.
3. Double-click on the row or press Enter.
4. Talk.
Call a Group
1. Press Home (Group) or click on the Group Call
button
. Available groups will be listed in
the Selection and details field.
2. Enter the group number/name to filter the list
or select it with the mouse. Navigate with the
up and down arrows to make your selection.
3. Double-click on the row or press Enter.
4. Talk.
End a Call
Click on the End Call button
1. Press - (Terminate).
2. Press ENTER.

Radio Status
Signal strength, audio volume setting and current
call status are displayed in this field.
Calling up

or:

Ongoing call
Open mic, you can speak.
Other handset is active, you cannot speak.
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Layout

Invalid Reports

Reports have of two sections:
• Search Criteria
• Generated Report

The statistics reports are usually based on
information gathered from the vehicle reports.
These vehicle reports can sometimes be invalid and
excluded from the data in the statistics reports. These
are the most common reasons:
• Incorrect or insufficient traffic data / geography
• GPS is missing or is incorrect
• Odometer is incorrect
• The driver is on a wrong journey/block or has
done an incorrect repositioning

Search
Criteria

Generated Report

When the report is generated, the Report
Content Selection section is automatically
minimized.

Tooltips

You can maximise it by clicking on the

Many charts have tooltips for their bars, dots, etc.

expand button
either to look at your
parameters or to modify them for a new
report.

Export to Excel
The raw data from all reports can be exported to
Excel by clicking on the Excel button in the Function
bar or by via File -> Send to Excel.

Search Criteria

Generated Report

Search Criteria
The search criteria vary from report to report
and we will go into each of them in their
respective section.
It is possible that the Search Criteria section
needs to update between your various
selections, so you might have to wait until
the options are no longer greyed out before
continuing.
It can also take some time to generate a
report, mostly if you search through a lot of
data and/or over a long time interval.

Where is When?
Intervals can be a little tricky at times.
The deviation intervals for the pie charts are represented by the image below. A filled circle
means that the vehicle report is included in the pie section. The same concept applies to the
Deviation report's bar chart.
E.g., The vehicle is on-time until 3 minutes. At 3:01, it becomes late.

Very Early

Very Late
Early

Late

Discard
Early
-1:00:00

Discard
Late

On Time

-0:03:00

-0:00:30

0:03:00

0:07:00

1:00:00
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Function

List a day's assignments with all
incurred issues for assessment of
assignment performance.

Search Criteria

Assignment Table
Each row shows a planned block with separate columns for various block-related
information. The graphic area, Block, Journey Graph, includes the block's journeys and
arrows for assignment events.

1. Select a calendar day
2. Company: select one or many companies.
Use SHIFT or CTRL to make your selection.
3. Click on Generate Report.

Incorrect Assignments Errors
Not assigned

Journey has not been assigned to any vehicle.

Late assignment:
Central

Journey has not been centrally assigned before the
journey start.

Journey Assignment Status

Early DeAssignment: Central

Journey has been centrally de-assigned before it was
finished.

A journey that ran smoothly is blue. An empty run is dark grey and shorter than
the others. A journey with at least one incorrect assignment error is red.

Late Assignment:
Driver

Journey has not been manually assigned before the
journey start.

Early DeAssignment: Driver

Journey has been manually de-assigned before it was
finished. Note: if the journey was completed, it will not
count as early de-assignment.

Overlapping
Assignments

Overlapping of two vehicle assignments to the same
journey. Note: it does not include reinforcements.

Failed Assignment

A vehicle has been assigned but has not correctly
acknowledged the assignment because of technical
issues.

Assignment Events
•
•
•
•

Black line: Central assignments
Grey line: Manual assignments
Green line: Reinforcement
Dashed line: The difference between when the
central assignment was done and when the vehicle
acknowledged it, usually due to the vehicle not running
yet.
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Function

Tracking and logging of vehicles running
in "charter mode", i.e. outside the
standard contracts.

Search Criteria
1. Time Interval: Select from and to dates.
2. Companies: Select one or multiple companies
(depending on your access). You can use the
free text filter to narrow down the list.
3. Vehicles: Select one or multiple vehicles. You
can use the free text filter to narrow down the
list.
4. Click on Generate Report.

Table

Shortcut Menus

The report lists individual “charter sessions”
with time stamps, driven distance, duration and
passenger data (if available).

Right-click on a row to open the short-cut
menu vehicle.

The top filter section includes a free text filter and
a charter [type] filter menu.
Vehicle

Vehicle number/name

Company

Company system name

Charter

The charter type selected for the session
(available types are configured per
customer).

Start

Time stamp: Session start date, time.

End

Time stamp: Session end date, time.

The report consists of 2 areas:

Distance

Driven distance.

Filter: A free text filter helps you narrow down the
table to your specific text/numbers.

Time

Session duration.

Boarding

Total number of boarding passengers,
according to passenger counting system.

Alighting

Total number of alighting passengers,
according to passenger counting system.

Report

Table: List of all the travels driven for the selected
time interval, companies and vehicles while in
charter mode.

Notes
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Function

Show various system and traffic problems for
selected day and previous 30 days for trends.

Problem List

Search Criteria - Upper Row
1. Calendar: Select a date, it has to be a completed
day, i.e., today's data is not available yet. Click on
Search.
2. Company: Change the selected company if
applicable/have proper rights.
Date & Company

Left side: The pie chart and the Problem
List show data for the selected day.
Right side: The area chart and line chart
show data for the latest 30 days from
the selected date.

Pie Chart

Area Chart

Problem List

Line Chart

List of all problems. Each row has an expand arrow, a
check box, the name of the problem surrounded by a red
bar and the percent of units experiencing this problem. The
red bar graphically illustrates the percentage. Note that
these numbers come from the “Vehicles in operation” and
“Unknown” parts of the pie chart. Hoover your mouse over
a problem area for a description of the problem.
• Click on the expand arrow to show, for that problem,
the top 10 guilty parties.
• Multiple problem-lists can be expanded at the same
time.
• Tick the check box to show this problem in the line
chart to the right. Each ticked check box is assigned a
different matching color.

Pie Chart

Line Chart

Quick overview of the broken, test, unknown and operating
vehicles as set/configured in the depot.

Lines showing data for the past 30 days for up to 10 different problems at a
time. The color of the line matches the color of the check box in the Problem
List. Note that colors are randomly assigned and not related to any specific
problem.

Broken: Vehicle which has been
marked as broken in the depot.
Test: Vehicle which has been marked
as a “test vehicle” in the depot.
Unknown: Vehicle which has been
marked with a state that cannot be interpreted in depot.
Vehicle in operation: Vehicle which is not marked by any state
and considered to be working and in operation.

Area Chart
The area chart shows the daily amount of operating vehicles, in
percentage, for the past 30 days. It uses the same X-axis as the line
chart located below.
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Function

Good for troubleshooting and/or analyzing
what has happened in details.

Search Criteria
The Search Criteria fields vary depending
on the basis for the visualization. You
can select between Vehicle, Block, Line/
Journey and Duty and Loops depending
on your system.
Include Vehicle Information / Include Loop
Information
• Include Vehicle Information is always preselected
and lets you see ALL vehicle reports.
• Include Loop Information is never preselected.
Checking it will add the loop reports, like enter/
leave.
Selection: Vehicle
Look at one vehicle at a time.
1. Type: Select Vehicle in the drop-down menu.
2. Time interval: Select one date. Uncheck Traffic Day
to pick specific from/to times.
3. Company: Change the selected company if
applicable/have proper rights.
4. Vehicle: Select ONE vehicle in the list.
5. Click on Generate Report.

Selection: Line, Journey
Look at all vehicles servicing one or all journeys
from a selected line.
1. Type: Select Line, Journey in the drop-down
menu.
2. Time interval: Select one date. Uncheck
Traffic Day to pick specific from/to times.
3. Company: Change the selected company if
applicable/have proper rights.
4. Line: Select ONE line in the list.
5. Journeys: Check "Show all Journeys" to
include all of them, or select ONE in the list.
6. Click on Generate Report.

Color-coded rows
The deviation time column is color-coded
so you can see with a quick look if a
section of the journey deviated from the
timetable.
The colors have brighter and darker
shades to indicate the severity of the
deviation. Blue is late and red is early.

Selection: Loops
Look at limited information from all the vehicles
that have driven by.
1. Type: Select Loops in the drop-down menu.
2. Time interval: Select one date. Uncheck
Traffic Day to pick specific from/to times.
3. Loop: Select ONE loop in the list.
The information provided from the loops is
vehicle ID, stop point name, event type, system
date/time, vehicle date/time and the difference
between them.
Notes

Selection: Block / Duty
Look at all vehicles servicing a specific block or duty.
1. Type: Select Block (or Duty) in the drop-down menu.
2. Time interval: Select one date. Uncheck Traffic Day
to pick specific from/to times.
3. Company: Change the selected company if
applicable/have proper rights.
4. Block: Select ONE block (or duty) in the list.
5. Click on Generate Report.
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Function

Overview of the vehicles' timetable adherence
by 30 seconds intervals and their comparison
between companies or lines.

The Deviations report uses comparisons to generate the
bar chart. If you choose No comparison, you will only
get the amount of departures without specifications.
Note: This report is based on departure reports from
timing stop points. To include all stop points, uncheck
the "Show data for timing points only" above the
Generate buttons.

Search Criteria
1. Time Span: Select from and to dates.
2. Charts: Choose if you want to compare per
company, line or not at all.
3. Selection:
3.1 Optional: Select a principality (business area).
3.2 Lines: Select up to 32 lines. If you prefer to use
Line Groups for a faster selection, make sure to
uncheck "All Lines".
3.3 Optional: Companies: Select one or multiple
companies, if applicable.
3.4 Optional: Traffic Types: Narrow the results by
selecting one or many types, like morning rush
traffic.
3.5 Optional: Weekdays: Select one or many
weekdays.
3.6 Optional: Line Groups: Use it to simplify your
selection if you have a lot of lines. Make sure
to uncheck "All Lines" or to include them in the
maximum of 32.
4. Click on Generate Report.
Note: You can only select up to 32 lines / 32 companies.

Deviation Tab - Optional

Pie Charts
The Deviations report has three pie charts. To keep
it simple for most users, the important information
in the first two pie charts is the light green area in
Planned Departures, which represents All departures
with valid reports. These reports are those used to
generate the Valid Planned Departure and Departures:
Deviation from timetable charts. This green area
should be as high as possible, to give you the most
accurate data for your fleet.
Valid Planned Departures,
the third pie chart, shows the
punctuality status of all the
departures with valid report.
Remember that, if you chose
No comparison, there will be
no line chart.

Departures: Deviation from Timetable Chart
Each bar is divided in sections (lines or companies),
and each has its own color and is stated in the legend,
e.g., blue is line 2, red is line 3.

Journeys/Departures reports are valid if:
• The vehicle is correctly assigned and
reports from the journey. Note that a
vehicle manually assigned in a system
with central assignments, will have its
reports considered invalid.
• The vehicle time and system time do not
differ too much.
• The reports come in the right order
(sequence number).
• The stop point is right according to the
assignment and traffic data.
Journeys/Departures without report can be
due to:
• No vehicle has driven the journey.
• The vehicle on the journey had
communication issues.
• The assignment is missing, so the
vehicle is driving without reporting from
a journey.
• Note that reinforced journeys are not
included in this report.

Each section of a bar has its value shown, as long as
it is not too small. If so, use the tooltip to read it (or
export the report to Excel).
Each bar covers 30 seconds. Their height corresponds
to the total of departure reports for that time interval.
The background of the chart is divided in colored
sections.
• Red = very early
• Light red = early
• Green = on time
• Blue = late

Deviation Times: Define new limits for the various
deviation categories.
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Function

Energy consumption per logged
journey.

Table

Notes

Each row corresponds to a journey.
Vehicle

Vehicle number

Block

Block serviced

Line

Line serviced

Journey

Journey serviced

Start

Journey start time

End

Journey end time

Distance [km]

Route length

Battery

Battery capacity [kWh).

Change SoC [%]

Difference between SoC at start of journey
and at the end. (How much the battery
charge has been lowered, in percent)

Report

Energy Consumption
[kWh]

Calculated energy consumption: Battery
[capacity] * SoC (diff)

Graph button
• Click on the Graph button to show the SoC
graph. Its background will turn dark grey.

Energy Consumption
[kWh]/[km]

Calculated energy consumption per km:
Battery [capacity] * SoC (diff)/route length
[km]

Search Criteria
1. Time Interval: Select from and to dates.
2. Vehicles: Select one, multiple or all vehicles.
You can use the free text filter to filter the
list.
3. Click on Generate Report.
Note: If the specific vehicle battery capacity is not
available, a generic default value will be used and
displayed in grey. For reliable results, make sure
that the correct battery capacity data is imported
into the system.

Filter
• Type words/numbers to filter the table after
specific values.
Table
• List of all the journeys driven for the
selected time interval and vehicles.
SoC Graph
• Graph of the selected journey in the table
(highlight in orange).

State of Charge Graph
Select a row and click on the Graph button to expand the
graph section.
The Y-axis shows the State of Charge values in %. The
X-axis shows the journey's length in meters.
Once opened, you can change the graph by clicking on
another row/using up & down arrows.

Shortcut Menus
Right-click on a row to open the short-cut
menu for the journey, vehicle, line and
block.
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Function

Visualize the interval between each
departure at a stop point, providing
information about flow and frequency.

Note that a departure is registered and valid as long
as the vehicle drives by the stop while servicing a
planned journey. It is not required for it to stop/open
its doors.

Search Criteria
1. Time Span: Select a time span. You can choose a
time interval via From/to and then pick the days
of your choice in the box to the right. You can
also click on 24 hours for the last 24 hours or 1
week for the previous week.
2. Selection
2.1 (Optional) Leave it to All, or select a
principality (business area).
2.2 Choose All lines or select a few in the list.
You can also select All line groups or pick a
few in the list.
2.3 Select the Starting stop point.
2.4 (Optional) Select a ending stop point to
narrow the result to show only departures
for vehicles driving through both the stops.
3. Optional
3.1 Include Non-Planned Reinforcement:
Check this to include data from reinforced
journeys.
3.2 Include On Demand Journeys: Check this to
include data from on demand journeys.
4. Click on Generate Report.

Headway Bar Chart
The bar's height shows the time between this departure
and the next one. The time is written inside or at the
end of the bar as hh:mm:ss.
The X-axis shows each departure as Destination (line,
journey, block), departure time.
If
It is possible to have very high bars (a very long interval
between two departures). These show up when there
is no traffic driving by that stop point, which usually
happens during the night as most lines will be stopped
until the next morning.

Example of a very high bar.

Non-Planned Reinforced Departures / On
Demand Journeys
These two types of departures, if included, will
be shown in light grey.
Note: When exporting the report, non-planned
reinforced departures (those reported by
vehicles assigned as reinforcements on the
block-journey) will be marked “X” in the
Reinforcement column.

Notes

CONSAT TELEMATICS

Traffic Studio - Training Material

| p. 117

Journey Time
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Function

Examine travel time and
deviation for all stop points on a
route.

Search Criteria
1. Dates: Select the from and to dates.
• Use specific dates and weekdays to
narrow the results.
2. Time Interval (optional, but
recommended): You can specify a time
interval, e.g., morning rush hours.
3. Line Groups (optional): Select a line group
to narrow your next options.
4. Select a line.
5. Select a route. Note that "Empty Runs" are
separated from the normal journeys.
6. Select one or many journeys. You can also
tick the All journeys check box to include
them all.
7. Click on Generate Report.
Note: We strongly recommend to use weekdays
and time intervals in order to compare
similar data. If you want to analyze/improve
the timetable, you might not want to bunch
together data from a Monday morning rush,
and data from a Sunday afternoon.

Color-coded rows
The tabletable deviation columns are colourcoded to quickly identify if a section of the
route deviated from the timetable.
The colors have brighter
and darker shades to
indicate the severity of
the deviation. Blue is
late and red is early.

Main Table

Extra information about specific journey

Each row shows the average and maximum values
for each stop points along the journey. If there are
any route alternatives, they will be displayed with
their own table beneath (scroll down).

Click on the cell of a bolded value (maximum columns) to
open a small table with extra information about which
journey generated it. Close it by clicking on any nonbolded cell.

* The last row shows the sum of all the average time.

The new section consists of planned and reported data
about the journey, its assigned vehicle, etc.

** The numbers within parentheses show the
amount of vehicle reports on which the value is
based.
Stop Name

Stop point name

Stop ID

ID number of the stop point.

Avg Planned
Drive Time

Average planned time to reach this stop

Avg Drive Time

Average logged time to reach this stop

Maximum
Drive Time

Maximum logged time to reach this stop

Avg At-Stop
Time

Average stay time at the stop point. Pass-by
are included and count as “0” second.

Max At-Stop
Time

Maximum stay time at the stop point.

Avg Door Open
Time

Average time with any door open at stop
point. Note: Pass-by are included and count
as 0.

Max Door Open
Time

Maximum time with any door open at the
stop point.

Avg Early
Deviation Time

Average derivation time for early departure
from the stop point.

Max Early
Deviation Time

Maximum derivation time for early
departure from the stop point.

Avg Late
Derivation
Time

Average derivation time for late departure
from the stop point.

Max Late
Derivation
Time

Maximum derivation time for late
departure from the stop point.

Average
Absolute
Deviation Time

Average deviation time in absolute values.

Stop Point Name

The stop point's name.

Stop Point ID

ID number of the stop point.

Sequence Number

Sequence of the stop point in the
journey.

Planned Arrival Time

Planned arrival time at the stop point.

Planned Departure
Time

Planned departure from stop point.

Arrival Time

Actual arrival time to stop point.

Departure Time

Actual departure time from stop point.

Door Open

The total time the doors were open at
the stop point.

Vehicle

Vehicle number

At-Stop

Actual stay time at that stop point.
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Filters
Filter the data so you can focus on the information which is relevant for you. The filters let you limit the data to a specific segment of the route, exclude journeys with
extreme deviation times and even show driving times by departures (stop points).

Select a Segment of the Route

Exclude Journeys with Excessive Deviations

Modify the From/to stop points to filter the table to a segment of the
whole journey/route. The total row at the bottom will only include the
times from these stop points.
1. Click on the From drop-down menu and select the first stop of the
sequence.
2. Click on the To drop-down menu and select the last stop of the
sequence. Note that the choice made for the first stop point will filter
the choices available.
3. Click on the Filter button to update the table.

Exclude journeys with high deviations from the results.
1. Check the box next to “Exclude journeys with deviation more than”.
2. Select a time from the drop-down menus for hours, minutes and
seconds.
3. Click on the Filter button to update the report.

Journey [types]: Planned and/or reinforcement traffic
Include data from planned journeys and/or reinforcement traffic. Use the
drop-down menu and click on Update to update the table.

Show Driving Times by Departures
You can swap the table to display the driving times by departures
instead. Check the box “Group time by departure, interval” and click
on Filter.
Driving times can be displayed in two ways.
• Show Time Accumulated: The driving time is summed from one
stop point to another, so the last stop point shows the average
driving time for the whole journey.
• Individually: Each stop point has its own driving time from the
previous stop point. Uncheck "Show Time Accumulated" for this
option.
All other filter options are also available for this view.
Note: The bolded column shows the average planned drive times.
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Function

Planned and logged driving data,
summarized by line.

Search Criteria
1. Dates: Select the from and to dates.
• Use specific dates and weekdays to narrow
the results.
2. Line Group (optional): Select a Line Group to
filter the next choices.
3. Select line(s). Tick the All Lines check box to
select all your lines.
4. Journey Types (optional): Include/exclude
different journey types.
• Normal Journeys and Empty Runs are
included by default. Untick them to exclude
them.
• Include Planned Reinforcement, On Demand
Journeys and Non-Planned Reinforcement
by ticking their boxes.
5. Click on Generate Report.

Report
The report has two sections:
• The Lines Table lists all the lines with a
summary of their data.
• The Line Detail Table lists all planned journeys
servicing the selected line, with planned
and logged departures and distances for
comparison.
Journeys without enough data

Lines Table (top)

Line Detail Table (bottom)

Each row corresponds to one line and shows
planned and logged information for comparison
purposes.

Planned and reported data for all planned journeys,
for the selected line (row) in the Lines Table above.

Line

Line name.

Σ Planned
Journeys

Number of planned journeys.

Σ Actual
Journeys

Number of reported journeys.

Σ Reinforcement
Journeys (if
included)

Number of reported journeys, by
vehicles assigned as reinforcements on
the line.
Note: Two vehicles reinforcing
the same journey counts as 2
reinforcement journeys.

Traffic Day

The service day of the planned journey.

Vehicle

The vehicle number

Line

Line name

Block

Block number

Journey

Journey number

Journey Type

The type of journey, such as Normal,
Empty run and Reinforcement.

Destination

Journey's destination.

Planned
Departures

The number of planned departures.

Actual
Departures

The reported departures by the vehicle
servicing the journey.

Σ Planned
Departures

Number of planned stop point
departures.

Σ Actual
Departures

Number of reported departures. If the
actual traffic matches the planned
traffic perfectly, the presented number
is equal to the number of planned
departures.

Planned
Distance (km)

The length of the planned journey route.

Σ Planned
Distance

The planned driven distance for all
planned journeys.

On-Route
Distance (km)

Σ On-Route
Distance (km)

The reported on-route driven distance.

The logged driven distance by the vehicle
reporting on the journey when the
planned route was followed.

Σ Off-Route
Distance (km)

The reported driven distance, off-route.

Off-Route
Distance (km)

The logged driven distance by the vehicle
reporting on the route, when the planned
route was not followed.

Distance
Difference (%)

The difference, in percent, between the
planned and reported (on-route plus
off-route) distance values for the line.

Reported/
Planned
Distance (%)

The difference in percent between the
driven (on- and off-route) and planned
distances, indicated in the columns to the
left.

(If no vehicle has reported on the journey,
the number will be “0”.)

Note: If the actual distance exceeds the
planned distance the percentage value
presented will be negative.

A warning symbol indicates when there is not
enough data available for a particular journey to be
included in the Lines Table.
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Function

Examine travel time and
deviation for all stop points along
a link.

Search Criteria
1. Dates: Select the from and to dates.
• Use specific dates and weekdays to
narrow the results.
2. Link Selection:
2.1 From: Select the
first stop of the
link.
2.2 To: Select the
last stop of the
link.
3. Select line(s).
4. Select journey(s).
You can add/
remove journeys
from the list by
using the Journey
Type filter.
5. Click on Generate
Report.

Color-coded rows
The tabletable deviation columns are colourcoded to quickly identify if a section of the route
deviated from the timetable.
The colors have brighter and darker shades to
indicate the
severity of the
deviation. Blue
is late and red
is early.

Main Table
Each row shows the average, minimum and
maximum values for each stop points on the link.
If there are any route alternatives, they will be
displayed with their own table beneath (scroll
down).
* The last row shows the sum of all the average time.
** The numbers within parentheses show the
amount of vehicle reports on which the value is
based.
Stop Point/Area
& ID

Stop point/area name & ID number

Planned
Distance

Planned distance between this stop and
the last one.

Avg Odometer
Distance

Logged distance between this stop and the
last one.

Avg Planned
Drive Time

Average planned time to reach this stop.

Avg Drive Time

Average logged time to reach this stop.

Minimum Drive
Time

Minimum logged time to reach this stop.

Maximum
Drive Time

Maximum logged time to reach this stop.

Avg At-Stop
Time

Average stay time at the stop point. Pass-by
are included and count as “0” second.

Max At-Stop
Time

Maximum stay time at the stop point.

Avg Door Open
Time

Average time with any door open at stop
point. Note: Pass-by are included and count
as 0.

Max Door Open
Time

Maximum time with any door open at the
stop point.

Avg Early
Deviation Time

Average derivation time for early departure
from the stop point.

Max Early
Deviation Time

Maximum derivation time for early
departure from the stop point.

Avg Late
Derivation Time

Average derivation time for late departure
from the stop point.

Max Late
Derivation Time

Maximum derivation time for late departure
from the stop point.

Average Absolute
Deviation Time

Average deviation time in absolute values.

Deviation
Distribution Early/
Late

Representation in percents of the reports,
divided by early/late.

Avg Passengers
(Show APC data)

The mean number of passengers aboard,
boarding and alighting.
Note: This column is only visible with the
Show APC data box checked.

Extra information about specific journey
Click on the cell of a bolded value (maximum columns)
to open a small table with extra information about
which journey generated it. Close it by clicking on any
non-bolded cell.
Stop Point Name

The stop point's name.

Stop Point ID

ID number of the stop point.

Sequence Number

Sequence of the stop point in the
journey.

Vehicle

Vehicle number

Planned Arrival Time

Planned arrival time at the stop point.

Planned Departure
Time

Planned departure from stop point.

Arrival Time

Actual arrival time to stop point.

Departure Time

Actual departure time from stop point.

Door Open Time

The total time the doors were open at
the stop point.

Passengers
(Show APC data)

The total number of passengers aboard,
boarding and alighting.
Note: This column is only visible with
the Show APC data box checked.
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Filters
You can decide which data to display so you can focus on the information which is relevant for you. The filters let you limit the data to a specific time interval, exclude
journeys with extreme deviation times and even show driving times by departures (summery of driving time by journeys, for each stop areas/points).

Select a Time Interval

Exclude Journeys with Excessive Deviations

Filter the journeys to those that started within the selected time interval,
without having to select them manually in the Search Criteria.
1. Select the time interval with the From and To fields. A time with a
(+1d) denotes that this specific time is on the next calendar day.
2. Click on the Update button to update the table.

Exclude journeys with high deviations from the results.
1. Check the box next to “Exclude journeys with deviation more than”.
2. Select a time from the drop-down menus for hours, minutes and
seconds.
3. Click on the Update button to update the report.

If you have both stop areas and stop points in your system, you
can display the results by areas or points. Click on Update to apply
the changes.

Journey [types]: Planned and/or reinforcement traffic
Include data from planned journeys and/or reinforcement traffic. Use the
drop-down menu and click on Update to update the table.

Show APC data
Check this box to include the Avg Passengers column in the report. Note
that this only affects the initial report explained on the previous page.

Show Driving Times by Departures
You can swap the table to display the driving times by departures instead. Check
the box “Group time by departure, interval” and click on Update.
By default the report is grouped by routes passing the same stop areas. You can
tick “Stop Point” instead to group line-journeys passing the same stop points.
Driving times can be displayed with many variations of "Arrival" and "Departure".
You can also show the time as Individually or Accumulated (Time from first...).
All these choices are available by using the Time: drop-down menu.
Remember to update your selections by clicking on the Update button.
All other filter options are also available for this view.
Note: The bolded column shows the average planned drive times.
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Function

Show logged passenger counter
data as averages by journey, by
stop point.

Search Criteria
1. Select the report type Journey.
2. Dates: Select the from and to dates.
• Use specific dates and weekdays to
narrow the results.
3. Time (optional): Select the time interval.
4. Line Group (optional): Select a Line
Group to filter the next choices.
5. Select one line.
6. Select one route.
7. Select journey(s). You can add/remove
journeys from the list by using the
Journey Type filter.
8. Click on Generate Report.

Main View

Data View

The Main View shows the data as a graph and as a
table.

The Data View has the Include invalid data filter, but
also Include vehicles without counters filter to include
planned departures. Refer to Main View for similar
columns, such as Max seat, km.

Note: the report include all logged journeys,
including reinforced journeys.
Journey start

Journey's start time

Time

Date and planned departure time.

Journey
name

Journey's name/number.

Vehicle

Vehicle number

# of
Journeys
with APC

Number of journeys serviced by vehicles with
APC systems / Number of planned journeys.

Journey

Journey's number.

Destination

Journey's destination name.

Index

Stop point’s sequence on the route.

Stop Point

Stop point name.

Stop Point

Stop point name

In

Number of passenger boarding at the stop point.

Avg In

Average number of passenger boarding at a stop

Out

Same as above, for alighting.

Avg Out

Average number of passenger alighting at a stop

Onboard

Number of passenger onboard when the vehicle
leaves the stop point.

Avg Onboard

Average number of passenger on board when
leaving a stop point.

Validity

The validity status of the data:

Distance

Distance from previous stop (link length).

∑ Passengers
km, seat

Passengers(seated) up to vehicle seat capacity *
distance

∑ Passengers
km, other

Passengers (non-seated) above vehicle seat
capacity * distance

∑ Passengers
km

(Sum of seated passengers and other (nonseated) passengers) * distance.

Main View

Max Seat km

The number of seats * distance

Data View

Max Capacity
km

(The number of seats + the number of standing
space for passengers) * distance

# Report for
link

Number of logged departures for this link /
number of planned departures.

Report
The report has two presentation modes: the
Main view (default) and a Data view.
You can switch between them with the buttons
at the upper left corner of the generated report.

Use the Route Section filter to only include
part of the selected route.

Note that the check box Include invalid data
is mostly used for testing purposes to include
reports that are technically incorrect.

• Valid (ok)
• Invalid: at least one of the passenger reports on
the route has an active fault.
• ”-“ Unknown validity (old data without validity
flag).
Validity
Description

Comment/description if invalid.

Avg onboard: If passengers have stayed
onboard from the previous journey:
(avg. passengers from last journey + avg.
passengers at first stop) Avg. total passengers onboard
when leaving first stop.
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Function

Show passenger counter
average and total values for
each route of the selected lines.

Search Criteria
1. Select the report type Lines.
2. Dates: Select the from and to dates.
• Use specific dates and weekdays to
narrow the results.
3. Line Group (optional): Select a Line
Group to filter the next choices.
4. Select one or multiple lines.
5. Click on Generate Report.
Note: If there is a lot of data, the report will
still start showing results while a progress
bar in the upper right corner will let you
know how far it has gotten.

Report
The report has two presentation modes: the
Main view (default) and a Data view.
You can switch between them with the buttons
at the upper left corner of the generated report.
Main View
Data View
Note that the check box Include invalid data
is mostly used for testing purposes to include
reports that are technically incorrect.

Main View

Data View

The Main View shows APC data for each route used
for each selected line.

This Data View has the Include invalid data filer, but
also Include vehicles without counters filter to include
planned departures. Refer to Main View for similar
columns, such as Max seat, km.

Note: the report include all logged journeys,
including reinforced journeys.
Lines

Line number/name

Route

The line-route (sorted in alphabetical
order).

Already
Onboard

Total number of passengers already on
board when the route starts.

∑ In

The total number of passengers boarding
on the route.

∑ Out

Same as above, for alighting.

Left Onboard

Total number of passengers that stayed
onboard when route ended.

Avg In

Average number of passenger boarding at
a stop

Avg Out

Average number of passenger alighting at
a stop

Avg Onboard

Average number of passenger on board
when leaving a stop point.

Distance

Distance from previous stop (link length).

∑ Passengers
km, seat

Passengers(seated) up to vehicle seat
capacity * distance

∑ Passengers
km, other

Passengers (non-seated) above vehicle seat
capacity * distance

∑ Passengers
km

(Sum of seated passengers and other (nonseated) passengers) * distance.

Max Seat km

The number of seats * distance

Max Capacity
km

(The number of seats + the number of
standing space for passengers) * distance

# Report for
link

Number of logged departures for this link /
number of planned departures.

Day/Time

Date and planned departure time.

Line

Line name/number

Route

Route name

Journey

Journey number

Destination

Journey Destination

# Links

The logged travelled links / planned links.

Max
onboard

The maximum number of passengers on-board at
any time on the journey.

Max
onboard (%)

The maximum vehicle occupancy (100% = all seats
taken, 200% = all seats and standing places taken).

Total # Stop
Points

Number of planned stop points.

# Valid stop
points

Valid departure reports from stop points.

# Passed by
Stop Points

Number of pass-by departures for the journey.

# Invalid
Stop Points

Number of invalid stop point.
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Function

Show passenger counter
average and total values for
each stop point along a route.

Search Criteria
1. Select the report type Route.
2. Dates: Select the from and to dates.
• Use specific dates and weekdays to
narrow the results.
3. Time (optional): Select the time interval.
4. Line Group (optional): Select a Line
Group to filter the next choices.
5. Select one line.
6. Select one route.
7. Select journey(s). You can add/remove
journeys from the list by using the
Journey Type filter.
8. Click on Generate Report.

Report
The report has two presentation modes: the
Main view (default) and a Data view.
You can switch between them with the buttons
at the upper left corner of the generated report.
Main View
Data View
Use the Route Section filter to only include
part of the selected route.

Note that the check box Include invalid data
is mostly used for testing purposes to include
reports that are technically incorrect.

Main View

Data View

The Main View shows the data as a graph and as a
table.

The Data View has the Include invalid data filter, but
also Include vehicles without counters filter to include
planned departures. Refer to Main View for similar
columns, such as Max seat, km.

Note: the report include all logged journeys,
including reinforced journeys.

Day/Time

Date and planned departure time.

Vehicle

Vehicle number

Journey

Journey's number.

Destination

Journey's destination name.

Index in
Journey

The stop point index/sequence number.

Stop Point

Stop point name.

Average number of passenger alighting at
a stop

In

Number of passenger boarding at the stop point.

Out

Same as above, for alighting.

Avg Onboard

Average number of passenger on board
when leaving a stop point.

Onboard

Number of passenger onboard when the vehicle
leaves the stop point.

Distance

Distance from previous stop (link length).

Validity

The validity status of the data:

Max Seat km

The number of seats * distance

Max Capacity
km

(The number of seats + the number of
standing space for passengers) * distance

∑ Passengers
km, seat

Passengers(seated) up to vehicle seat
capacity * distance

∑ Passengers
km, other

Passengers (non-seated) above vehicle seat
capacity * distance

∑ Passengers
km

(Sum of seated passengers and other (nonseated) passengers) * distance.

# Stops with
APC

Number of logged departures by vehicles
with passenger counters compared to the
planned number of planned departures.

# Report for
link

Number of logged departures for this link /
number of planned departures.

Index

Stop point’s sequence on the route.

Stop Point

Stop point name.

∑ In

The total number of passengers boarding
at the stop.

∑ Out

Same as above, for alighting.

Avg In

Average number of passenger boarding at
a stop

Avg Out

• Valid (ok)
• Invalid: at least one of the passenger reports on
the route has an active fault.
• ”-“ Unknown validity (old data without validity
flag).
Validity
Description

Comment/description if invalid.

Avg onboard: If passengers have stayed
onboard from the previous journey:
(avg. passengers from last journey + avg.
passengers at first stop) Avg. total passengers onboard
when leaving first stop.
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Function

Show passenger counter
average and total values for
each selected stop point.

Search Criteria

Details View
The Details View shows a graph for every journey logged at all the selected stop areas/points. The table
below lists all these journeys individually.
Filter the data with the free text filter and the Line filter. This will affect both the graph and the table.

1. Select the report type Stop Point.
2. Dates: Select the from and to dates.
• Use specific dates and weekdays to narrow
the results.
3. Time (optional): Select the time interval.
4. Stop Area: Select one or multiple stop areas/
points. Use the filter to narrow the list.
5. Click on Generate Report.

Graph: Toggle the view between 24 hours with 1 hour intervals, and Days of the Week with 7 days interval.
Day/Time

Date and planned departure time.

Vehicle

Vehicle number

Line

Journey's line

Journey

Journey's number.

Destination

Journey's destination name.

Index in Journey

The stop point index/sequence number in the journey.

Stop Point

Stop point name.

In

Number of passenger boarding at the stop point.

The report has two presentation modes: the
Summary view (default) and the Detail view.

Out

Same as above, for alighting.

Onboard

Number of passenger onboard when the vehicle leaves the stop point.

You can switch between them with the tabs at the
upper left corner of the generated report.

Validity

The validity status of the data:

Report

• Valid (ok)
• Invalid: at least one of the passenger reports on the route has an active fault.
• ”-“ Unknown validity (old data without validity flag).
Validity Description

Comment/description if invalid.

Summary View
The Summary View shows the data for each selected stop area/point. Click on a row
to reveal a second table for that stop area/point with the data grouped by line.
Stop Point

Stop point name.

∑ In

The total number of passengers boarding at the stop.

∑ Out

Same as above, for alighting.

∑ Onboard

Same as above, for onboard.

Avg In

Average number of passenger boarding at a stop

Avg Out

Average number of passenger alighting at a stop

Avg Onboard

Average number of passenger on board when leaving a stop point.

# Journeys with APC

Number of logged journeys by vehicles with passenger counters.
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Function

Show the differences between
reported boarding and alighting
numbers from each vehicle.

Search Criteria
1. Select the report type Vehicle.
2. Dates: Select the from and to dates.
• Use specific dates and weekdays to
narrow the results.
3. Time (optional): Select the time interval.
4. Select vehicle(s). You can use the filter to
narrow the list.
5. Click on Generate Report.

Report
The report has two presentation modes: the
Main view (default) and a Data view.
You can switch between them with the buttons
at the upper left corner of the generated report.

Top Table (all selected vehicles)

Data View

Click on any row to visualize that vehicle's daily
differences in the graph.

Use this view to analyze the data “behind” the main view
presentation. Each row corresponds to a journey.

Vehicle

Vehicle number

Vehicle

Vehicle number.

Difference

The difference, in percent, between ∑ In
and ∑ Out.

Date

The date the journey was reported.

∑ In

The total number of passengers boarding
at the stop.

Line

The line the journey serviced.

Journey

The journey ID

∑ Out

Same as above, for alighting.

Destination

The journey destination.

Journeys

Number of logged journeys compared to
the number of planned journeys.

Journey start

The planned start time of the journey.

Date

Date

Already
Onboard

Passengers who stayed in the vehicle from the
last journey.

Difference

Same as table above.

∑ In

∑ In

Same as table above.

The total number of passengers boarding at the
stop.

∑ Out

Same as table above.

∑ Out

Same as above, for alighting.

Journeys

Same as table above.

Left Onboard

Passengers who stayed on board to the next
journey.

Excluded
Days

Non-interactive indicator showing days
with excluded data because of total
boarding numbers below the threshold
filter setting.

Difference

The difference, in percent, between ∑ In and ∑
Out.

Validity

The validity status of the data:

Main View
Data View
The Main View has a graph that lets you compare
the difference of all vehicles against the selected
vehicle in the table. The differences are listed by
date on the X-axis. To select a vehicle in the table,
simply click on its row which will be highlighted
in orange.

Excluded
Invalid
Journeys

• Valid (ok)
• Invalid: at least one of the passenger reports
on the route has an active fault.
• ”-“ Unknown validity (old data without
validity flag).

The excluded individual journeys
presented in this format: Line A (Journey
A, Journey B, Journey C), Line B (Journey
D), etc.).
Validity
Description

Comment/description if invalid.

The table is split in two sections: The Top Table
lists all the vehicles. The Bottom Table shows the
historical data for the selected vehicle.
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Function

Present the complete APC raw data
for selected vehicle(s). Excellent for
troubleshooting.

Details

In Summary, sort the table with Difference In/
Out (%). In a normal system, the average should
be below 5%. Always compare the % with the
raw numbers.

Search Criteria
1. Select the report type Vehicle Raw Data.
2. Dates: Select the from and to dates.
• Use specific dates and weekdays to narrow
the results.
3. Select vehicle(s). You can use the filter to
narrow the list.
4. Click on Generate Report.

Report
The report has three modes: Summary (default),
Details and Departures w/o any APC report.
Summary lists all selected vehicles.
Details has a graph comparing boarding/
alighting data, and a table listing each
departure for ONE vehicle. Selecting a row
provides extra information about doors and
counts.

Basic Troubleshooting

Departures without any apc report lists all
departures missing at least one APC report, so
you can find holes in the data. Check "Search
for departures w/o any APC report" to generate
its content.

In Summary, sort the table by "# Invalid Data". Note that
having numbers in this column is NOT necessarily an issue.
For a month, anything below 100 is most likely ok, though it
is never wrong to double-check.

Departures w/o any APC report

2. Difference Between Boarding and Alighting

Note: a more detailed guide for APC troubleshooting is
available on the portal.
1. Invalid Data

Select a vehicle with a high number, then go to Details.
• Flat curves: Something is wrong, can likely be that the
sensors are/were not communicating. You can often
look further into it with Details. Sort that table by Invalid
Data, then click on any row with "No Communication".
Expand "Doors" to see which sensor(s) is not
communicating.

An average above 5% can be due to one of many
of the following factors:
• The APC sensors are wrongly calibrated.
• The driver boarded before the vehicle (and
the sensors) were turned on. However,
sensors will power off 15-30 minutes after
the vehicle is turned off. That’s already a
difference of 1 for that day. Take it over
a month, and you might have a normal
difference of 20-30. Have a vehicle with
a break in the middle of the day, and
you're up to 40-60. For vehicles with few
passengers, it can be misleading when only
looking at the difference in % (see vehicle
4728 below).
• Passengers come on or off while the vehicle
was not powered. Not usual at schools and
terminals.
• The sensors are wrongly mounted. Can
happen after maintenance.
• The cable is disconnected, so the sensor has
no power.

Vehicle

In

Out

Difference

Difference %

4728

138

156

18

11.5%

1193

2039

2054

15

0.7%

• Curves growing apart: It is possible that the contact is
loose with the sensors. Check and test them.
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Function

Overview of the vehicles' punctuality and
compare it between companies or lines.

The Punctuality report uses comparisons to generate
the bar chart. If you choose No comparison, you
will only get the amount of departures without
specifications.
Note: This report is based on departure reports from
timing stop points. To include all stop points, uncheck
the "Show data for timing points only" above the
Generate buttons.

Search Criteria
1. Time Span: Select from and to dates.
2. Charts:
2.1 Choose comparison mode between company,
line or none.
2.2 Select the interval for grouping the data.
3. Selection:
3.1 Optional: Select a principality (business area).
3.2 Lines: Select up to 32 lines. If you prefer to use
Line Groups for a faster selection, make sure
to uncheck "All Lines".
3.3 Optional: Companies: Select one or multiple
companies, if applicable.
3.4 Optional: Traffic Types: Narrow the results
by selecting one or many types, like morning
rush traffic.
3.5 Optional: Weekdays: Select one or many
weekdays.
3.6 Optional: Line Groups: Use it to simplify your
selection if you have a lot of lines. Make sure
to uncheck "All Lines" or to include them in
the maximum of 32.
4. Click on Generate Report.
Note: You can only select up to 32 lines / 32 companies.

Deviation Tab - Optional
Deviation Times: Define new limits for the various
deviation categories.
Y-Axis: Define the values for the Y-axis. The default is
automatic where the
application chooses
the limits that do not
exclude any of the
results.
If you select
percentage, you can
set the upper and
lower limits of the
Y-axis.

Pie Charts
The Punctuality report has two pie charts. To keep it
simple for most users, the important information in
these pie charts is the light green area in Planned
Departures, which represents All
departures with valid reports.
These reports are those used to
generate the Punctuality line chart
below. This green area should be
as high as possible, to give you the
most accurate data for your fleet.

Journeys/Departures reports are valid if:
• The vehicle is correctly assigned and
reports from the journey. Note that a
vehicle manually assigned in a system
with central assignments, will have its
reports considered invalid.
• The vehicle time and system time do not
differ too much.
• The reports come in the right order
(sequence number).
• The stop point is right according to the
assignment and traffic data.
Journeys/Departures without report can be
due to:
• No vehicle has driven the journey.
• The vehicle on the journey had
communication issues.
• The assignment is missing, so the
vehicle is driving without reporting from
a journey.
• Note that reinforced journeys are not
included in this report.

Punctuality Line Chart
Each company or line has its own graphic line, symbol
and color in the chart. The legend located below the
X-axis will tell you which is which.
The X-axis represents the time interval and is
displayed according to how you chose to show the time
interval.
The Y-axis represents the percentage of departures on
time during the specified time interval.
Remember that, if you chose No comparison, there
will be no line chart.
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Function

Show all 200+ generated vehicle events over time in a table and
on the map. Heat map function helps to identify problem areas.

Search Criteria
1. Time Span: Select from and to dates.
2. Selection Type:
2.1 Vehicle: All events generated by the selected vehicle(s).
2.2 Line: All events generated by vehicles assigned to selected line.
2.3 Area: All events generated in the selected area.
2.3.1 Enable the Selection mode in the Map
2.3.2 Use the right mouse button to draw a rectangle over the
area of your choice.
3. Filter: Narrow the result of your search. The available filters vary
depending on your selection type.
4. Click on Generate Report.

Planned Traffic Data
Use planned traffic in combination with RouteChecker to compare driven vs. planned
activities. The planned information will be displayed in blue on the map.
1. Tools -> Planned Traffic.
2. Show a specific route and its stops via Blocks & Journeys or Lines & Routes.
• Click on a journey under Blocks & Journeys.
• Click on a route under Lines & Routes to show this one on the map in blue.
3. Click on a stop area or a stop point under Stop Areas & Stop Points to show them/it.
Each stop point is surrounded by a blue circle showing the 25 meters radius used to
record arrival and departure from a stop point.

Automatic Filters. The table updates automatically as you use it.
• Free text filter: Type in numbers and/or letters
"Update" Filters. Click on the Filter button to apply any changes.
• Time interval: Drag the sliders to narrow the daily time interval.
• Drop-down filters: Narrow to specific event types/vehicles/journeys.

Heat Map
The Heat Map is a graphical “intensity map” showing
the local density of the listed events.

Use the toggle buttons at the far right to show/hide map elements.
• Event dots: The position where each event has been recorded
• Lines between the events: A link between the recorded events
• Heat Map: Shows the concentration of events.

Route Checker on the Map
Each report is shown in the
map as colored dots. Hold
your mouse over the dots
and a tooltip will appear
with information such as
creation type, even type,
source, etc.

The colors range from green, yellow, orange to red (few
to most).
To activate the Heat Map, click on the toggle button
located to the far right in the tool bar

.

Note that if you make changes after activating the Heat
Map, you will need to click the button off and on again
to update the Heat Map.

Finding Wrongly Positioned Stop Point
Use planned and logged traffic data to identify problems
such as an erroneous stop point location in the database.
In this example, a majority of grey dots for "unexpected
door open" are shown outside the 25 meters radius.
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Function

Show comprehensive statistics on
planned journeys/departures compared
to actually driven journeys/departures.

Search Criteria
1. Dates: Select the from and to dates. You can also
narrow your selection to include/remove specific
dates and weekdays.
2. Deviation Thresholds (optional): Change the
timetable deviation thresholds. Those marked
with a star * are the default vehicle values which
can trigger the report reason popup in the driver
display (if enabled).
3. Line Group (optional): Select a Line Group to filter
the next choices.
4. Select line(s). You can also tick the All Lines check
box to include them all.
5. Click on Generate Report.

Lines Table (top)

Line Detail Table (bottom)

Each row shows total of deviations, per category,
per line.

The table lists all the individual deviations for the
selected line in the table above.

The last row, Total, sums all the columns for the
selected lines.

If a deviation affects more than one consecutive stop
point, the number of additional affected stop points
are listed as +X. E.g. "Early departure +3" means there
is a total of 4 consecutive early departures for this
journey from the listed stop point.

Line

Line and Company

Journeys
(Reported /
Planned)

The number of driven/planned
journeys.

Departures
(Reported /
Planned)

The number of driven/planned
departures from stop points.

Journeys not
driven

The number of planned journeys that
were not driven (no report).

Journeys
incomplete

The number of journeys where the
vehicle did not report from all the stop
points on its route.
Possible causes:

Note! Searching and filtering through all this data is
time-consuming and may take several minutes if the
report covers both a long time period and many lines.

Report
The report has two tables.
• Summary Table: One row per line with a
summary for each column
• Journey Deviations Table: All journeys with
deviations for the selected line in the Summary
Table.
Deviation Type Filter
Use the deviation type drop-down filter to narrow
the list to specific deviation(s).

• The vehicle was off-route and
missed the stop point(s).
• The journey started after the first
stop point or was terminated before
the last stop point.
Journeys late to
start point
Late Departures
(Threshold)

Number of departures over than X*
minutes late.

Early Departures
(Threshold)

Number of departures over X* minutes
early.

Late Journeys
Start (Threshold)

Number of journey starts over X*
minutes late.

Early Journeys
Start (Threshold)

Number of journey starts over X*
minutes early.

Departures
Reinforced

Number of departures on the line
reported by reinforcing vehicles.

Journeys
Reinforced

Number of journeys on the line
reported by reinforcing vehicles.

Activated
On Demand
[Journeys]

The number of activated/serviced on
demand journeys.

Deviation/
Cause

The type of deviation, some can be
bundled together, e.g.,

Journey

The journey ID

Block
Destination

The journey destination.

Vehicle

The vehicle servicing the journey.

* Stop Point

The stop point where the deviation was
recorded.

* Planned
Departure

The planned departure time, according to
the timetable.

* Actual
Departure

The actual time of departure, at the stop
point where the deviation was logged.

Deviation (color
coded)

The deviation from the timetable.

Date

The date when the deviation occurred.

Cause

The cause of a deviation reported by the
driver/traffic controller.

Comment

Deviation comment(s) entered in the
Traffic Deviations tool or included in
Traffic Changes ticket.

Tips

Use multiple columns to sort the data.
Use SHIFT while clicking on column
headers to continue sorting from one to
multiple headers.
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Function

Show all vehicle reports for selected
vehicles, lines or blocks, as well as
the logged routes on the map.

Each vehicle/line/block is presented with its
own color in the table and on the map.
All individual vehicle reports in the search
are listed chronologically, including detailed
information about the vehicle status at the
time.
The report can play back selected parts of the
logged traffic for detailed analysis, using the
playback controls, or by stepping up/down in
the list using the arrow keys. As the report
can cover multiple vehicles, you can analyze
connections, APC information for reinforcing
assignments on a line, etc.

Search Criteria
1. Date: Select one day.
2. Time: Select the time interval.
3. Choose a selection type between vehicles,
blocks or lines.
4. Select your vehicle(s), block(s) or line(s)
with their check box. Use the free text
filter to quickly find the right items.
5. Click on Generate Report.

Report
The report has a map and a table.
• Map: All reported events are showed on
the map and linked to visualize how each
vehicle drove.
• Table: Every reported vehicle event is
listed in chronological order. This table
cannot be sorted as it would disable the
playback function.

Table

Filters
Free text filter: Type in numbers and/or letters

Vehicle

Vehicle heading, presentation color, GPS
heading and vehicle number.

Vehicle Status

Symbols for Doors open & Stop button
pressed.

Passengers

The number of passengers aboard,
boarding, alighting

Block

Block number and operator

Line

Line number and operator

Duty

Duty serviced, if available

Driver

Logged in driver (if available)

Destination

The Destination of the journey.

Journey

Journey number

Journey Status

Journey status

Stop

Previous stop point

Distance

Distance to the previous known stop when
the vehicle report was sent.

Deviation

Deviation from the time table

Stay Time

Stay time at stop.

Assigned

Assigned block number

System Time

Time from the central system.

Vehicle Time

Time from the vehicle.

Vehicle Label Presentation

Sequence
Number

The vehicle report sequence number.

Valid flags

Administrator information

Configure the vehicle's label, both on the map and in the
Vehicle column of the table by ticking the information
you wish to include in the label.

Event

The type of vehicle report, e.g., arrival, door
close, pass-by, etc.

Sign control

How the vehicle signs were controlled: No
text (automatic)/ “Manual” / “External”
(controlled by external sign controller
unit).

Event Seq. no

Sequence number for the information in
the Event and Sign control columns.

Speed (optional)

The speed reported by the vehicle.

Latitude

Latitude position (GPS)

Longitude

Longitude position (GPS)

Event Filter: Contains all types of generated events in
the table.
Note: The filters only affects the list. The map always
shows the whole searched data.

Playback Controls
These controls are located between the map and the
table. They include playback buttons, a time slider for
and label settings.
The speed controls are located to the right. They range
from real time (1x) to five times (5x) and twenty times
(20x) faster. Select one and press the Play button located
to the left of the timeline.
Note: You can also navigate the map by clicking on a row
in the table. Click and hold the down arrow key to play
though the vehicle reports on the map at your own pace
(or up to go back).
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Function

Show how well the vehicles
are reporting and how well
the assignments are working.

The Vehicle Assignment and
Communication report works best for
systems with central assignments. If
your system uses manual assignments
(drivers), then you will miss a lot of data
in the charts.

Search Criteria
1. Company: Select one company or all
of them if applicable.
2. Type: Choose between Unique
vehicles reporting and All vehicle
reports.
3. Interval:
3.1 Calender day: Select a day. Today
is selected by default.
3.2 Time Interval (optional): Narrow
the time interval.
4. Click on Generate Report.
Note that if you choose "Today", the data
has not all been gathered yet and the
charts will be incomplete.

Two Types of Upper Charts
You have two choices for the type of upper
chart.
Unique Vehicles Reporting: Shows the
number of vehicles which have sent at
least one report during each interval.
This chart will have four bars for each
30-minutes interval.
All Vehicles Reporting: Shows the total
number of vehicle reports from all
reporting vehicles. It only shows the
"Number of vehicle reports" grey bar in the
chart.

Upper Chart

All Vehicles Reporting

Unique Vehicles Reporting

The X-axis is divided by periods of 30 minutes.

The X-axis is divided by intervals of 30 minutes.
Grey bar: Number
of unique vehicles
to have sent at least
one report to the
central server. The
report is valid even
if the vehicle is reporting outside
a journey’s specified time.
Yellow bar: Number of planned
blocks with at least one journey.

Lower Chart - Assignments and vehicles reports

Blue bar: Number of assigned blocks that are also part
of the grey bar.

This chart is the same regardless of the Upper Chart
type. It shows the relation, in percentage, between
assigned/reporting vehicles and planned/assigned
blocks. This line chart has 3 curves.

Green bar: Number of blocks having vehicles
reporting on their journey. They are also part of the
yellow bar.
In a perfect situation, the green and blue bars will be
at the same height, which means that all the journeys
of the assigned blocks have been reporting.
Example: A vehicle is planned and assigned to drive a
journey between 10:00 and 12:00.
Vehicle 1 is out driving and reporting between 09:45 to
12:15.
From 09:45 to 10:00: Vehicle 1 will only be included in
the Grey bar.

compared to planned traffic

Blue: Percentage of assigned vehicles versus planned
blocks.
Red: Percentage of reporting vehicles versus assigned
blocks. It should be as close to 100% as possible since
every vehicle should, in theory, be reporting.
Black: Percentage of reporting vehicles versus planned
blocks. It cannot be above Curve 1 as an unassigned
vehicle cannot send reports.

From 10:00 to 12:00: Vehicle 1 will be included in the
Grey and Green bars.
From 12:00 to 12:15: Vehicle 1 will only be included in
the Grey bar.
Vehicle 2 is out driving and reporting between 10:15 to
11:30.
From 10:00 to 11:30: Vehicle 2 is included in the Grey
and Green bars.
From 11:30 to 12:00: Vehicle 2 will not be included in
any bar as it did not report or communicate.
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Function

List speed reports for one vehicle in
a table and on the map.

This report is different from the others as
it opens in the Lower Tool Window. Once
generated, it also displays that information in
the Map.

Search Criteria
1. Dates/times: Select the from and to dates
and times.
2. Select a vehicle
3. Click on Generate Report.
Keep in mind that if you select a broad time
interval, the application will take longer to
generate the report and the map might be
cluttered with events.

Vehicle Speed Report || Map

Events Types

Vehicle speed report || Statistics Table

The vehicle’s speed is below the
speed limit.

Each of its row represents an event and gives general
information about the vehicle ID, the selected time
interval, the maximum speed recorded, the time it was
recorded as well as the mean speed during that period.

Door opened

Double-click on a row to zoom to it on the map.

The vehicle’s speed is above a
defined value.

Door closed

System time

System time when the message was received by
the central system.

Reason for the report, e.g.,
odometer (distance driven), Time
limit (timer), GPS heading, etc.

Vehicle time

Vehicle time when the message was sent to the
central system.

Event type

Type of event recorded. See the table above for the
description of each event and their icon.

Event speed

Current speed of the vehicle when the event
occurred.

Maximum
speed

Maximum speed of the vehicle since the last
vehicle report.

Minimum
speed

Minimum speed of the vehicle since the last
vehicle report.

The maximum speed of the
vehicle between two events.

You need to have the Map to see this part of the
report.

Notes

Once generated, it will show the vehicle’s route(s) by
linking all the reported events.
Each event has its own symbol. Holding the mouse
over the events/symbols will open the tooltip
information about the event type, the vehicle ID, the
time the event was recorded and the speed of the
vehicle at that event.
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